same user name for different domain

Discussion in 'Installation/Configuration' started by hanswid, May 26, 2008.

  1. hanswid

    hanswid New Member

    by default, looks like ISPConfig wouldn't allow us to have 2 same user or email on different domain (correct me if i m wrong).

    I have several domain my my machine, and let's say I have email hans@domain1.com and when i try to create different user hans@domain2.com, ISPConfig will refuses it and saying that user 'hans' exist. Is there any setting that we can set to enable 2 same user name on different domain?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You mix up usernames and email addresses. You can have email addresses hans@domain1.com and when i try to create different user hans@domain2.com on the same server, thats why ISPConfig uses the username prefix. If ISPConfig complains about identical users, you might have disabled the username prefix.
     
  3. hanswid

    hanswid New Member

    yes, i turned it off coz it's look funny to have email web1_hans@domain1.com, and FTP user like web1_hans. I dont want to have that prefix.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Username != Email address. You have a separate field for the email address, so the email address is not web1_hans@domain1.com.

    Linux system user names are alwyas unique for the whole server, thats the way linux works and nothing special in ISPConfig.
     
  5. hanswid

    hanswid New Member

    so in this case, it doesn't matter whether I use prefix or not, there is no way that i can have email hans@domain1.com and hans@domain2.com as the time? ISPConfig uses kind of /etc/passwd file? one user for one email address, got nothing to do with different domain?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please read my above posts again:

    1) Username != email address.
    2) You may have hans@domain1.com and hans@domain2.com for sure, I told you that above.

    the steps are:

    1) Activate the user prefix again, you should never deactivetd it.
    2) Create the two email addresses hans@domain1.com and hans@domain2.com

    You can have 200 sites on your server and every site has its own email address info@.... without problems.
     
  7. hanswid

    hanswid New Member

    thx, sorry a newbie. I will try it now.
     
  8. hanswid

    hanswid New Member

    i tried and still failed. i activated prefix now. So in User & Email tab looks like this :

    - Email address : hans@domain1.com
    - Username : igi-hans <=== uses 'igi' as prefix
    - Password : mypassword

    I saved it, and tried it with Thunderbird. If i use hans as login, it will fail, but if i use igi-hans, login will OK. Meaning, that I have to use igi-hans@domain1.com instead of hans@domain1.com.

    But i try using webmail, both hans and igi-hans can login without problem. But mail send to other like Yahoo always appears as igi-hans, not hans.

    Is there any other setting that i missed??
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    This failed for sure. You have to restore the original prefix "web[WEBID]_" as it contains a variable.

    No, not at all. The third time: USERNAME != EMAIL ADDRESS

    You must set the correct sender address in your mail client.
     

Share This Page