Same host 'www' at (n) domain at the same ip doesn't work

Discussion in 'Installation/Configuration' started by OdinsChrist, Nov 14, 2006.

Thread Status:
Not open for further replies.
  1. OdinsChrist

    OdinsChrist New Member

    Maybe I've got a similar problem with bind9. Sorry, that I'm asking for that but I don't find an answer which fits my probs.

    I'm new to dns with Linux. Resp. I've got not much experience with it.

    Configuration:
    Code:
    Unbuntu 6.06 [U]Intranet[/U] Server
    ISPConfig 2.7.7
    
    Hostname: odin
    Domainname: intranet.svc
    eth0:192.168.2.12
    eth0:0:192.168.2.13
    
    After installation I'm logged in by https://192.168.2.12:81/. Works.

    I'd created a DNS Master Entry for the IP 192.168.2.12 which listens for intranet.svc. Works.

    Then I'd created a web.
    www.intranet.home at IP 192.168.2.13. Works after reboot of the server... Why? Maybe the refresh needs more time I'll spend to wait for it. Nevertheless:

    Then I'd created a second web.
    www.typo3.home at IP 192.168.2.13. Doesn't work. Why?

    I'd tried something. After a while I'd deleted the www A Record from typo3.home. NOW http://typo3.home works, but why? Maybe that bind don't like more than one A Record with the same name for the same IP. That's my mind. But how can i solve that Problem?

    If I want to re-add the www A Record to the typo3.home domain an error occurs which means host is already in zone. It's to confusing for me. I read some summaries of official Bind9 docs. But I can't follow it.

    For an accurate answer I'll thanks in advance.

    Bye Chris

    Sorry for my english... If you may help me for a better conversation please send me an IM with an error correction :) [for the german readers: 'Hauptschule 9. Klasse' :D ]
     
    Last edited: Nov 15, 2006
  2. till

    till Super Moderator

    You can have as many A-Records for the IP as you like. Please check your syslog or messages log for errors.

    Also hav a look in the ISPConfig logfile /home/admispconfig/ispconfig/ispconfig.log
     
  3. OdinsChrist

    OdinsChrist New Member

    Now it works. Problems with my 2nd DNS.

    Hi!

    Now it works! There was no problem with bind.

    My 2nd DNS (slave) didn't work correctly. It's a hardware router from avm... Strange and stessful!

    Sorry for the big Mexican wave!

    Bye Chriss

    @Mod: - please close -

    PS: And... Please mind to empty the recycle bins! It's very important!
     
    Last edited: Nov 16, 2006
Thread Status:
Not open for further replies.

Share This Page