Samba Hard Drive Issues

Discussion in 'Server Operation' started by atjensen11, Sep 5, 2008.

  1. atjensen11

    atjensen11 New Member

    I have a Samba machine setup as a VM on a Xen host. The OS for the machine and swap are on disk image files. There is another drive that is formatted as NTFS for the data that Samba shares out. It is mounted in fstab with ntfs-3g option.

    Last night, I noticed that several files were no longer visible when browsing the shared network drive from a Windows client. I found it odd that when I tried to create a new folder with the same name, I received a I/O error message.

    I then logged onto the Samba console and browsed to the path where the folder (and files) should be. Issuing an "ls -la"1 command showed the folder, but all of the statistics such as size and ownership about the folder were question marks.

    I then ran the command ”ntfsresize -fi /dev/sda4” as I found this will perform a check on the consistency of an NTFS partition in Linux. I received multiple errors saying cylinders had multiple or redundant references. I am sorry that I can't give the specific error messages as the drive isn't in the machine current to reproduce the error. The results of the ntfsresize command also suggested that I remove the drive and run the chkdsk command on the drive from a Windows machine twice, both with the -f option to repair the filesystem.

    I did that and still cannot access the files.

    Is there any other suggestions from this board? Is there any idea what would have caused something like this to occur in the first place?

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. atjensen11

    atjensen11 New Member

    I did do that two nights ago and it did not appear to make a difference.

    Last night, I pulled all the files I could off of the drive and reformatted the drive as NTFS. I am going to run the ntfs resize command again and see if any similar errors are reported.
     
  4. atjensen11

    atjensen11 New Member

    I ran the ntfsresize command again this morning on the drive and it return a clean status.

    So I guess I will load my files back on and see how it runs the next few days.
     

Share This Page