SAMBA domain controller / CUPS

Discussion in 'HOWTO-Related Questions' started by gradedcheese, Dec 28, 2005.

  1. gradedcheese

    gradedcheese New Member

    Hello. I used this HOWTO:

    http://www.howtoforge.com/samba_setup_ubuntu_5.10

    to set up samba and it worked very well. However I cannot seem to get cups to work. On the fresh ubuntu install, I was able to use the gnome cups config tool to add my network printer (which has a static IP). After doing the steps in the HOWTO that tool no longer runs (it says that it cannot contact the cups server). My printer isn't listed in the 'Printers and Faxes' of the samba server under windows and I cannot browse for it.

    How do I go about making the gnome tool work again? Also, how does one make the printer show up in Samba aside from running 'cupsaddsmb -a'?

    I also cannot get the web frontend for cups to work, so perhaps I had done something incorrectly in general. I will re-check things as well.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If you cant connect with the gnome tool to the cups server and the webinterface is not working, i guess your cups server is not running at all or has not been started.

    Please all check the settings in /etc/cups/cupsd.conf

    Did you get an error message when you execute this command on the shell:

    /etc/init.d/cupsys restart

    There are no other steps. But if cups is not running at all, the printers wont show up in samba.
     
  3. gradedcheese

    gradedcheese New Member

    Hi. Cups starts and restarts fine but the gnome tool or the web config on port 631 don't work. I am double-checking the settings again now but I think they are like what is in the HOWTO. My setup is similar min that my server has a static IP.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If there is an error in the cups config file, cups will only start the server part that is nescessary for printing, but not the part that is nescessary for the communication with samba, the webinterface and other config tools. Please check the logfiles for errors too and check with netstat if the software listens on port 631.
     
  5. gradedcheese

    gradedcheese New Member

    Hi. I should have looked at a log earlier, I looked at /var/log/cups/error_log and found this when I restart cups:

    Code:
    I [28/Dec/2005:14:07:46 -0800] Listening to 7f000101:631
    I [28/Dec/2005:14:07:46 -0800] Listening to c0a801fc:631
    E [28/Dec/2005:14:07:46 -0800] Unknown directive AuthGroupName on line 711.
    I [28/Dec/2005:14:07:46 -0800] Loaded configuration file "/etc/cups/cupsd.conf"
    I [28/Dec/2005:14:07:46 -0800] Configured for up to 100 clients.
    I [28/Dec/2005:14:07:46 -0800] Allowing up to 100 client connections per host.
    I [28/Dec/2005:14:07:46 -0800] Full reload is required.
    E [28/Dec/2005:14:07:46 -0800] LoadAllClasses: Unable to open /etc/cups/classes.conf - No
    such file or directory
    I [28/Dec/2005:14:07:47 -0800] LoadPPDs: Read "/etc/cups/ppds.dat", 4104 PPDs...
    I [28/Dec/2005:14:07:47 -0800] LoadPPDs: No new or changed PPDs...
    I [28/Dec/2005:14:07:47 -0800] Full reload complete.
    X [28/Dec/2005:14:07:47 -0800] No Listen or Port lines were found to allow access via localhost
    So it seems that 'AuthGroupName' is not understood (it's one of the things that the HOWTO instructs me to add). Also, it apprears that I didn't set up listening correctly either.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I guess you put "AuthGroupName shadow" in the wrong part of the config file because its supported.

    Open the config file, search for AuthGroupName, you will find it commented out. Put the line AuthGroupName shadow right below the commented AuthGroupName line.
     
  7. gradedcheese

    gradedcheese New Member

    Thanks, I think 'AuthGroupName' is now in the right place, also I mistyped some addresses. I am pretty confident that the config file looks 'right' now. My error log has this:

    Code:
    I [28/Dec/2005:16:38:17 -0800] Listening to 7f000001:631
    I [28/Dec/2005:16:38:17 -0800] Loaded configuration file "/etc/cups/cupsd.conf"
    I [28/Dec/2005:16:38:17 -0800] Configured for up to 100 clients.
    I [28/Dec/2005:16:38:17 -0800] Allowing up to 100 client connections per host.
    I [28/Dec/2005:16:38:17 -0800] Full reload is required.
    E [28/Dec/2005:16:38:17 -0800] LoadAllClasses: Unable to open /etc/cups/classes.conf - No
    such file or directory
    I [28/Dec/2005:16:38:18 -0800] LoadPPDs: Read "/etc/cups/ppds.dat", 4104 PPDs...
    I [28/Dec/2005:16:38:18 -0800] LoadPPDs: No new or changed PPDs...
    I [28/Dec/2005:16:38:18 -0800] Full reload complete.
    
    I can now access the web admin page from my server, so i will try to see if I can set it up to show my printer via samba.
     
  8. gradedcheese

    gradedcheese New Member

    I just wanted to say that everything is working and the problems were indeed typos on my part. Thanks for your help! Now I need to figure out why Windows won't load the driver for the printer, even from the HP CD. However the samba/cups side seems to be working fine.
     
  9. dpsxl

    dpsxl New Member

    Did you find the solution to this problem? I'm having the same problem.

    My printer is printing fine on the linux side. When I tried to print from the XP Pro machine it says "wrong drivers for this printer." I've tried installing the drivers from the XP machine, but won't accept the them.
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which driver do you select on linux (cups) and which on windows?
     
  11. dpsxl

    dpsxl New Member

    Linux drivers:
    Epson Stylus Photo RX500 - Cups+Gimp-Printv.4.2.7

    XP machine:
    I downloaded and unzipped epson11326.exe.

    Here's the info about the drivers from Epson's website:
    Windows XP, Windows 2000
    epson11326.exe - 7.7MB - posted on 02/01/05

    I also tried the epson11376.exe with the same results.

    I got this error message "Windows cannot locate a suitable printer driver. Contact administrator..." after selecting the driver.
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  13. dpsxl

    dpsxl New Member

    Thank you very much.

    I was selecting "Connect to this printer" option (second option) and browse through the network and select the printer - THIS DID NOT WORK.

    I selected "Connect to a printer on the Internet or on a home or office work" option (third option) and enter:

    http://192.168.1.90:631/printers/Epson

    This allowed me to use the epson11326.exe drivers.

    I decided to install my laser printer (Brother HL5140) this way too and it's also working great from the XP machine.

    CUPS did not recognize any drivers for Brother, therefore I still can't use it from my linux machines.
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    What did you mean with recognize? You have to select the driver in the list. Or is your printer not listed there, then you should have a look at linuxprinting.org if your printer is supported by cups.
     
  15. dpsxl

    dpsxl New Member

    I'm sorry, I meant there were no drivers for Brother listed.

    Anyways, after reading the fourms on linuxpring.org I decided to download the HL5140 drivers directly off the Brother website.

    It's required to install the LPR drivers first before the CUPS wrappers. I received a few errors installing the LPR drivers, but they were just missing files and folders - which I created myself (assigning proper permission).

    I used the following commands to install the packages: dpkg -i --force-all <filename.deb>

    Now I can print from both the XP and Linux machines. :) Again, thanks for the help!
     
    Last edited: Mar 8, 2006

Share This Page