Salutatory Email for Clients problem

Discussion in 'Installation/Configuration' started by dimas, Oct 5, 2006.

  1. dimas

    dimas Member

    My system is ISPConfig 2.2.6 on Debian Sarge 3.1. I have a problem with Salutatory Email for Clients. If it is written only in English, everything is OK, but if I write there some Russian text, it appears like this when the email is received:

    & #1059;& #1074;& #1072;& #1078

    I guess I need to set the correct encoding, which is windows-1251, - but how can I do this?

    Thanks a lot in advance for your help!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    We will check that.
     
  3. falko

    falko Super Moderator ISPConfig Developer

    I've just added a fix for this in the SVN repository, so it will be available in ISPConfig 2.2.7. It would be good if you could test it (when it's released ;) ) and give us some feedback. :)
     
  4. dimas

    dimas Member

    Thank you very much for this, of course I'll gladly test it and give the feedback.
     
  5. dimas

    dimas Member

    Thank you for the release of Version 2.2.7! You say in the release notes
    - Added: Support for charsets in salutatory emails for clients and resellers.

    I installed it on top of 2.2.6 (everything went well) but I'm afraid I don't see any changes. Where can I set the encoding of salutatory emails? Management - Settings - Other looks the same to me. Am I missing the obvious?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can set the encoding in the file /home/admispconfig/ispconfig/config.inc.php
     
  7. dimas

    dimas Member

    Thank you, it works beautifully now. The only thing that I needed to do after making the charset change was to go to "Management - Settings - Other" and press 'save' for the changes to take effect.

    Thank you again.
     
  8. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    doesn't work for me?

    Hi,

    I have ISPConfig 2.2.9 on FC6

    the config is located in /home/admispconfig/ispconfig/lib/config.inc.php
    and the above doesn't work for me.
    I still receive mails with
    &#1081
    in them. The charset doesn't change anything, neither going to
    "Management - Settings - Other" and press 'save'

    What could be the solution?

    Thanks
     
  9. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    log in and out

    log out and log in worked for me
     
  10. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    Traffic exceedence

    Now, that I had the chance to receive a traffic exceedence email, I see that it's not in the correct encoding.
    The salutatory emails are comming with the correct - windows-1251 encoding, while the traffic exceedence ones are in KOI8-R

    Where is this setting? Aren't they supposed to get the same encoding as the salutatory ones?

    Regards,

    Apostol
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Please check the encoding in /home/admispconfig/ispconfig/lib/config.inc.php.
     
  12. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    windows-1251

    It's windows-1251. That's why the Salutatory Email works fine.
    But I wander why the Traffic Exceedence one is comming in KOI8-R and is unreadable, unless I force the email client to use windows-1251. And even after that the subject and sender remain in KOI8-R.

    Thanks.
     
  13. falko

    falko Super Moderator ISPConfig Developer

    We don't use KOI8-R anywhere in the sources... :confused:
    Maybe it's your server's default locale?
     
  14. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    I'm not russian. My server default locale is what comes with the default FC6 installation when one choses to use English.
    Anyway I'll think of it as of 50% bad for my clients.
    The salutatory mail is good. Only the traffic exceedence is BAD.

    Thanks.
     

Share This Page