Safe mode Off/On doesn't work

Discussion in 'Installation/Configuration' started by gilas, Jun 8, 2006.

  1. gilas

    gilas Member

    Hi, I'm newby at ISPConfig,
    I've installed it on Debian 3.1 Sarge, ISPConfig Version: 2.2.3
    (stable), just defined a new website I discovered that the flag
    Php safe mode on/off doesn't work propely.
    Then I modified the file /etc/apache2/vhosts:


    and force safe_mode = Off

    for the site just created.

    Hope this will be corrected, thanx
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Safemode works in ISPConfig 2.2.3. It is just a misconfiguration in your setup.

    Either you disable safemode in your php.ini globally, what is expected for ISPConfig 2.2.3.

    Or you change the value for the PHP engine in the file /home/admispconfig/ispconfig/lib/ to:

    $go_info["server"]["apache2_php"] = 'filter,addtype,engine';

    in the ISPConfig Development releases.

Share This Page