sa-stats.pl

Discussion in 'General' started by Strat72, Aug 31, 2006.

  1. Strat72

    Strat72 New Member

    I am trying to get some stats about spam... I am using sa-stats.pl to do this, but all i ever get is zero's for all stats... I have tried different versions / different commands for it as well..... I am running ISPConfig 2.26 ( the latest one ?? ) on a SUSE 10.0 system.

    Bare with me as I am a noob .. even though i been running a linux email / web server for a fseveral years, I know next to nuttin... I am a copy and paste type of guy :)

    I believe the reason why I am not getting any stats is that there is not enuff info in the mail logs...... example:

    Aug 31 11:19:56 ns1 postfix/cleanup[11468]: E92C61E8062: message-id=<[email protected]>
    Aug 31 11:19:56 ns1 postfix/qmgr[16439]: E92C61E8062: from=<[email protected]>, size=3157, nrcpt=1 (queue active)
    Aug 31 11:19:56 ns1 postfix/pickup[9711]: 4699B1E808B: uid=10026 from=<glenuk>
    Aug 31 11:19:56 ns1 postfix/cleanup[11468]: 4699B1E808B: message-id=<[email protected]>
    Aug 31 11:19:56 ns1 postfix/qmgr[16439]: 4699B1E808B: from=<[email protected]>, size=338, nrcpt=1 (queue active)
    Aug 31 11:19:56 ns1 postfix/local[11641]: 4699B1E808B: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
    Aug 31 11:19:56 ns1 postfix/qmgr[16439]: 4699B1E808B: removed
    Aug 31 11:19:57 ns1 postfix/local[11469]: E92C61E8062: to=<[email protected]>, orig_to=<[email protected]>, relay=local, delay=35, status=sent (delivered to command: /usr/bin/procmail -f-)
    Aug 31 11:19:57 ns1 postfix/qmgr[16439]: E92C61E8062: removed
    ___________________________________

    Am I way off base ???

    Any direction will be helpful !!!

    ( please rember I am a noob !!!!! )


    Strat
     
  2. edge

    edge Active Member Moderator

    I think that the problem is that SpamAssassin (the way it's setup with ISPconfig) does not log to mail.log.
    Because of that the script that you are using does not find the needed info to work.
     
  3. Strat72

    Strat72 New Member

    So I am out of luck then for getting any kind of stats ????

    Strat
     
  4. edge

    edge Active Member Moderator

    I've been at it some time, but did not get it to work.
    I think that you will need to change some settings in SpamAssassin.

    For sure falko or till know what.. Lets wait and see if they reply to this message,
     
    Last edited: Sep 1, 2006
  5. falko

    falko Super Moderator ISPConfig Developer

  6. Strat72

    Strat72 New Member

    Thanks... looked thru th elink you sent.. I will not bother at this time... at the moment, that thread is to jumpy for me... after a 4 day weekend, the mind is not set to work mode yet :)

    Thanks for for pointing me in the right direction !!!

    Strat72
     
  7. Ovidiu

    Ovidiu Active Member

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The main problem with this topic is that we will have to tell amavisd / spamd to read the user config files from ISPConfig. I described it in the thread you linked above.
     

Share This Page