SA points below configured limits, but mail still gets tagged as spam

Discussion in 'HOWTO-Related Questions' started by nl0pat, Apr 29, 2007.

  1. nl0pat

    nl0pat New Member

    Hi guys,

    I own a system running the "fedora_virtual_postfix_mysql_quota_courier" howto. And allmost all works well.
    Allmost yes, because somehow some mails get tagged as spam even if they are below the 8.0 points I've configured. (for instance 5.9 points, 8.0 required)
    Any ideas what could cause this strange behaviour ?
    Below follows a header of one of those mails.

    Spam detection software, running on the system "mysystem", has
    identified this incoming email as possible spam. The original message
    has been attached to this so you can view it (if it isn't spam) or label
    similar future email. If you have any questions, see
    the administrator of that system for details.

    Content preview: U ontvangt de tekstversie omdat uw systeem niet automatisch
    de HTML versie opent. Om deze versie online te bekijken, klik op de volgende
    link: [...]

    Content analysis details: (5.9 points, 8.0 required)

    pts rule name description
    ---- ---------------------- --------------------------------------------------
    4.3 SUBJ_ILLEGAL_CHARS Subject: has too many raw illegal characters
    0.1 TW_IJ BODY: Odd Letter Triples with IJ
    0.1 TW_JG BODY: Odd Letter Triples with JG
    -2.6 BAYES_00 BODY: Bayesian spam probability is 0 to 1%
    [score: 0.0000]
    0.0 HTML_MESSAGE BODY: HTML included in message
    0.3 MIME_8BIT_HEADER Message header contains 8-bit character
    -0.3 AWL AWL: From: address is in the auto white-list
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post the SpamAssassin settings from your amavisd configuration?
  3. nl0pat

    nl0pat New Member


    Thanks for your reply. I had searched for spam tag levels in the spamassassin configuration file, not in the amavisd configuration file. So you have pointed me in the right way. I found the following line:
    $sa_tag2_level_deflt = 4.0; # add 'spam detected' headers at that level
    and changed that to 8.0,
    I think this should solve my problem. One more thing the spam detected message is saying, is "8.0 required". Where is the setting of this value, because in my amavisd configuration file there is:
    $sa_dsn_cutoff_level = 10; # spam level beyond which a DSN is not sent
    or does this have nothing to do with the required points?
  4. falko

    falko Super Moderator ISPConfig Developer

    I think it's defined by $sa_kill_level_deflt.
  5. nl0pat

    nl0pat New Member

    I have set this variable to 10.0 , so why does the mail says 8.0 is required. I allready restarted amavis postfix and SA.
  6. falko

    falko Super Moderator ISPConfig Developer

    $sa_dsn_cutoff_level or $sa_kill_level_deflt?
  7. nl0pat

    nl0pat New Member

    the $sa_dsn_cutoff_level

    I think I see this issue here:
    $sa_tag2_level_deflt = 8.0; # add 'spam detected' headers at that level
    $sa_kill_level_deflt = $sa_tag2_level_deflt; # triggers spam evasive actions

    Here is that 8.0 specified, I think I need to change that $sa_tag2_level_deflt
  8. falko

    falko Super Moderator ISPConfig Developer

    You must change $sa_kill_level_deflt. In your case where $sa_kill_level_deflt = $sa_tag2_level_deflt, that's equal to changing $sa_tag2_level_deflt.

Share This Page