Russian domain names in ISPConfig 2

Discussion in 'General' started by dimas, Jun 9, 2010.

  1. dimas

    dimas Member

    I've searched through the forums - but I wasn't able to find any information on the Russian domain names, so please kindly help me.

    In fact, I've used the ISPConfig panel on my servers for 3 or more years - thanks again to the developers for their excellent software - but recently Russian domain names (that is, domain names that are displayed in Russian) came into being, and I can't add any such domain in ISPConfig.

    I wonder if there is any solution to this situation?
  2. falko

    falko Super Moderator ISPConfig Developer

  3. dimas

    dimas Member

    Dear Falko, thank you very much - if I add my Russian-language domain IDN-encoded (in punicode), it indeed works!


    The problem is that I have to manually edit /etc/apache2/vhosts/Vhosts_ispconfig.conf (the server's Debian Lenny) - because the ISPConfig panel doesn't allow to add IDN-encoded names in full - that is, it's OK to add such names before the final two-letter code of the domain, but I can't add "xn--p1ai" (which stands for "rf" - when written in Russian).

    Apparently, the panel performs a check to see if the domain zone is correctly entered - and it believes "xn--p1ai" to be incorrect...

    As you realize, the problem with manually editing of the vhosts file is that it is re-written every time a change is made via the panel...

    So I wonder if it's possible to make the ISPConfig panel bypass this check or (still better) make it consider the zones starting with "xn--" as correct ones?

    Thanks again for your great help!
  4. dimas

    dimas Member

    One more question, I'm sorry...

    Is it the same with ISPConfig 3 (I haven't tried it yet)?

    Does it support long international zone names?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I nrun a lot of IDN encoded domains in ISPConfig 2, so thats fully supported.

    Thats indeed incorrect, as you missed to add the toplevel domain.

    incorrect: xn--p1ai
  6. dimas

    dimas Member

    Dear Till, thank you for your reply, but that's exactly the problem!

    There's no "ru" in the new russian-language domains.

    The top level domain is now not "ru", but "рф" - it's written in Russian as well. So "xn--p1ai" (which stands for "рф") should be placed at the very end - and the panel sadly doesn't allow this.
  7. dimas

    dimas Member

    So there's no solution at the moment...?
  8. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker.
  9. falko

    falko Super Moderator ISPConfig Developer

    I've just fixed this.
  10. dimas

    dimas Member

    Thanks a lot! I'll update to 2.2.37 tonight and report back!
  11. dimas

    dimas Member

    Today is the day when Russian-language domain names have finally become open for registration for everybody, not just govenmental structures, trademark owners etc, so from now on these names' support will be very important for all users of ISPConfig in Russia.

    As for 2.2.37 - now it truly supports adding a site with a such a name (thank you very much for this - I checked, and it worked), but sadly it doesn't work on the DNS side of things. So, if I try to add a DNS record and put such a name in SOA - I get "invalid domain name".

    Is there a way to quick-fix it myself? I'm asking because I get literally dozens of requests for such domain names from my clients.

    Thank you!
  12. falko

    falko Super Moderator ISPConfig Developer

    I think you need to change the regular expression in /home/admispconfig/ispconfig/lib/classes/ispconfig_isp_dns.lib.php, e.g. in line 284:

            if (!preg_match("/^([a-z0-9\-]+\.)+[a-z]{2,6}$/ix", $soa["dns_soa"])) {
  13. dimas

    dimas Member

    Dear falko, you practically saved me by giving me the right clue!

    In fact, I changed the mentioned line to:

    if (!preg_match("/^([a-z0-9\-]+\.)+[a-z0-9\-]{2,8}$/ix", $soa["dns_soa"])) {

    - and I had to do in three other places in this file and also several times in "ptr" and "slave" dns libraries. I hope it's OK.

    Anyway, I can now assert that everything works - a number of such sites and DNS records are already successfully running on my servers.

    Is there a hope that these changes will make it to the future versions of ISPConfig 2 and ISPConfig 3 (which I haven't tried yet)?
  14. falko

    falko Super Moderator ISPConfig Developer

    I've added this to our bugtracker.
  15. falko

    falko Super Moderator ISPConfig Developer

    I've just fixed this in SVN. :)

Share This Page