Running ISPConfig On Port 80 Using Apache's Reverse Proxy Feature

Discussion in 'HOWTO-Related Questions' started by grandpagenocide, Nov 5, 2007.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    ok I am following the how to at http://www.howtoforge.com/apache_reverse_proxy_ispconfig and I am using Debian etch and ISPConfig dev 2.3.3. It does not go to the login, but keeps going to the shared ip page. Is there something else not in the tut? And I have quite a few clients who are running into port 81 blocks from gov buildings and firewalls
     
    Last edited: Nov 5, 2007
  2. trustadvert

    trustadvert New Member

    Hello,
    i have the same problem :(

    Trust
     
  3. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    has anyone had any success with this?
     
  4. trustadvert

    trustadvert New Member

    Yes!
    Yesterday it was running for me. I was playing around....
    Now again it is not running. I played around again ;)
     
  5. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    i cant seem to get it working at all. And I have about 10 clients who cant access port 81, so I have to keep them on my old email server and they only have ftp and ssh access. Im pulling my hair out. arghhhh
     
  6. falko

    falko Super Moderator ISPConfig Developer

    This indicates that you're using the wrong ServerName in your Apache configuration (or the wrong address in your browser).
     
  7. trustadvert

    trustadvert New Member

    In my configuration it is only running when i delete the following lines in the file Vhosts_ispconfig.conf:

    NameVirtualHost 69.94.125.172:80
    <VirtualHost 69.94.125.172:80>
    ServerName localhost
    ServerAdmin [email protected]
    DocumentRoot /var/www/sharedip
    </VirtualHost>

    Does anybody know why?

    Trust
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What URL do you use to access ISPConfig? What's in /etc/hosts?
     
  9. trustadvert

    trustadvert New Member

    I use the same URL as the servername is. The same as the http://host.mydom.com:81 but for port 80

    For the hosts file i must look when i am back home.
     
  10. trustadvert

    trustadvert New Member

    I have in my hosts:
    127.0.0.1 localhost
    69.94.125.172 host.mydom.com host

    When i go to http://host.mydom.com i come to the shared ip page.
     
    Last edited: Nov 7, 2007
  11. thryb

    thryb New Member

    So anyone got it working and found the problem ? I got the same problem. Everything seems allright.
    Does ispconfig.domain.com need to be in /etc/hosts ?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    I always have it in there, but it should work without it as well...
     
  13. trustadvert

    trustadvert New Member

    But why it is not working for us?

    It only work when i delete this lines:
    NameVirtualHost 69.94.125.172:80
    <VirtualHost 69.94.125.172:80>
    ServerName localhost
    ServerAdmin [email protected]
    DocumentRoot /var/www/sharedip
    </VirtualHost>

    Please help
     
  14. thryb

    thryb New Member

    I get the shared IP too, and if I remove those line its not working more, im juste going on the default www.domain.com
    Its really weird.


    I reviewed the tutorial like 100 times lol, char by char :p

    Can it have something to do with a wrong version or the proxy proxy_http modules ?
     
    Last edited: Nov 9, 2007
  15. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    adding in the IP of the machine in the virtual host got it working perfect thanks for the help falko. Any idea on how I can enable this in fedora as well, the proxy packages are different. I have 3 machines running IPSC with FC6.

    Edited 10 min later:--- ok got it for FC6 instead of editing apache2.com edit /home/admispconfig/ispconfig/lib/config.inc.php restart httpd and it works perfect thanks for the great work.
    /etc/httpd/conf/httpd.conf and
     
    Last edited: Nov 9, 2007
  16. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    ?
     
  17. thryb

    thryb New Member

    Just thought about something, I feel a bit retarded right now lol but if your ISPConfig was linking on www.domain.com:81
    should it be

    ProxyPass / http://www.domain.com:81/
    ProxyPassReverse / http://www.domain.com:81/

    will it still work if you added a A with ispconfig.domain.com ?


    EDIT: Everything is working ... it was a miss understanding of it by me, sorry about it :p
     
    Last edited: Nov 11, 2007

Share This Page