rtorrent local install

Discussion in 'HOWTO-Related Questions' started by lyp, Oct 19, 2008.

  1. lyp

    lyp New Member

    Thanks to http://www.howtoforge.com/compile-rtorrent-from-svn-ubuntu-8.04-hardy-heron I know all the dependencies to install rtorrent. But I save system installs for aptitude and manual compilations are local.

    Compiling libtorrent works fine, rtorrent does not. It seems it can't find the libtorrent files.

    This is my configure line:
    libtorrent_CFLAGS=/home/user/utils/rtorrent/include/ libtorrent_LIBS=/home/user/utils/rtorrent/lib/ ./configure --prefix=/home/user/utils/rtorrent/ --includedir=/home/user/utils/rtorrent/include/ --libdir=/home/user/utils/rtorrent/lib/
    (also tried without the --includedir and --libdir)

    but it still won't compile. The first error is:
    g++ -DHAVE_CONFIG_H -I. -I../.. -I. -I./.. -I../..    -g -O2 -g -DDEBUG -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include     /home/user/utils/rtorrent/include/ -MT curl_get.o -MD -MP -MF .deps/curl_get.Tpo -c -o curl_get.o curl_get.cc
    curl_get.cc:42:32: error: torrent/exceptions.h: No such file or directory
    I notice there is no -I before my local include dir so I tried the g++ line myself with the -I and it worked. So is the make file not being written right? What do I do?

  2. falko

    falko Super Moderator ISPConfig Developer

  3. lyp

    lyp New Member

    Thanks for trying to help. The actual solution was to use $PKG_CONFIG_PATH.
  4. sjau

    sjau Local Meanie Moderator

    never done a local install :) feel free to write an extensive howto on that :)

Share This Page