RTC problems on Dell Poweredge Servers

Discussion in 'Kernel Questions' started by Novacom, Jan 4, 2007.

  1. Novacom

    Novacom New Member

    Hi All !

    This one is a bit technical and i hope we come to a solution.

    I finally managed to install a VMWare server on Debien Etch kernel 2.6.18-3-686. Beside all the problems noted and fixed in another post I still have an issue related to RTC.

    This is what should happen on a normal system :

    Code:
    [root@testsystem ~] hwclock
    Wed 03 Jan 2007 06:07:26 PM EST  -0.758061 seconds
    
    [root@testsytem ~] cat /proc/interrupts
               CPU0
      (snip)
      8:          8    IO-APIC-edge  rtc
      (snip)
    
    The number 8 would increase beside IO-APIC-edge rtc showing that hwclock receives correct interrupts form /dev/rtc...

    That's not the case on the Dell PowerEdge 860.

    Code:
    [root@pe860 ~] hwclock
    select() to /dev/rtc to wait for clock tick timed out
    
    [root@pe860 ~] cat /proc/interrupts
               CPU0   CPU1
      (snip)
      8:          0       0    IO-APIC-edge  rtc
      (snip)
    
    This issue is corrected on Dell servers by adding --directisa option to a hwclock command or in /etc/init.d/hwclock.sh for booting slowdowns and shutdowns... But the issue is affecting directly VMware server.

    This message is logged in syslog

    Code:
    Jan  3 16:08:41 pe860 kernel: rtc: lost some interrupts at 2048Hz.
    Jan  3 16:09:12 pe860 last message repeated 1512 times
    Jan  3 16:10:13 pe860 last message repeated 3051 times
    
    The final issue is that the time on the virtual machine is sooooo slow. 1 sec = 5 sec realtime. This is I belive because /dev/rtc is broken and must be fixed in the kernel (or rtc module)

    At this point, any ideas are welcome.

    Thanks !

    Francis
     
    Last edited: Jan 5, 2007
  2. falko

    falko Super Moderator

    Are you talking about the host or the guest system?
     
  3. Novacom

    Novacom New Member

    RTC problem

    Hi Falko,

    I'm talking about the host system. It generates errors in syslog because a guest system needs the host's RTC to overcome the 1000 hz or so clock tick limit.

    I've tried to modprobe -r rtc , modprobe rtc-dev...

    hwclock works fine, but there is no /dev/rtc anymore in /proc/interrupts... this way, vmware is not able to cope with the rtc

    Beside that, haven't found anything yet !


    Francis
     
    Last edited: Jan 7, 2007
  4. falko

    falko Super Moderator

    And this happens only on a Dell server, not on other servers?
     
  5. Novacom

    Novacom New Member

    Hi Falko,

    Thanks for your time in this...

    I did my homework : It tried the same command (hwclock) on at least 8 of my Debian (sarge) servers. On these I have 2 Poweredge 430sc and 1 Poweredge 860. All of them show the behavior, no rtc interrupts possible. Even though I saw Dell was ok with Debian, having only problems with network and sas drivers. (wich are ok in etch).

    On the rest of the servers, they are all dffirents machine (an old IBM, some clones, on AMD + MSI mobo) they all have correct results regarding RTC.

    I'll post anything I find...


    Francis
     
  6. falko

    falko Super Moderator

  7. Novacom

    Novacom New Member

    Hi Falko !

    Finally the results of my adventures in RTC :) The debian based setup I use to have (debian sarge 3.1 and debian etch) were all wrong when rtc was needed. I finally moved the whole setup to Ubuntu (your perfect setup). It all went perfectly well on my Dell PE 860...

    I traced back the bug I had to the hpet timer function that were not implemented in debian sarge and etch. Having to recompile my kernel leaded to /dev/sda1 not being detect at boot (IDE - SATA order, other problems...argg) So I finally dropped Debian for Ubuntu LTS (not so different since Ubuntu is based on debian)...

    I liked Ubuntu very much, and it solved all my worries...

    My vmware (Ubuntu) server is now completed. I have Windows 2003 Web ed running + Ubuntu - ISP config running on the other vm. Everything looks cool !

    Thank you so much for all your help and wonderful control panel.


    Francis
     
  8. Toontje

    Toontje New Member

    Which Etch-ISO did you use?

    I have an AMD64 ISO (I have an AMD 3800+ on an ASUS A8V-VM SE MB), but I have problems installing the linux-headers.

    Edit:
    I should read better! You moved to Ubuntu....... Sorry:rolleyes:

    The problem is that 6.06 LTS doesn't support my Southbridge (VIA VT8237A), so I will try to install 6.10
     
    Last edited: Feb 21, 2007
  9. Novacom

    Novacom New Member

    Right now my server is working A1. No glitches. I now provide my own DNS on both ISPconfig servers. No bugs at all !

    Good Luck with 6.10. Should work like a charm.
     
  10. Toontje

    Toontje New Member

    Also installed 6.10 and no problemo at all!

    VMware server is running smooth and fine
     
  11. edge

    edge HowtoForge Supporter

    CIDM,

    I've got 2 Dell PowerEdge SC1425 with Debian Sarge on it.

    Not sure if this is okay, or not, but your commands are showing me this:
    Code:
    host:/home/edge# hwclock
    Sun 25 Feb 2007 04:07:10 PM CET  -0.274992 seconds
    
    Code:
    host:/home/edge# cat /proc/interrupts
               CPU0       CPU1       CPU2       CPU3
      0:        148          0          0 2203400325    IO-APIC-edge  timer
      9:          0          0          0          0   IO-APIC-level  acpi
     14:          0          0          1         12    IO-APIC-edge  ide0
    169:          0          0          0          0   IO-APIC-level  uhci_hcd
    177:          0          0          0          0   IO-APIC-level  uhci_hcd
    185:          0          0          0          1   IO-APIC-level  ehci_hcd
    201:          0          0          0 1504553283   IO-APIC-level  eth0
    209:          0          0          0  178945454   IO-APIC-level  3ware Storage Controller
    217:          0          0          0    3258702   IO-APIC-level  eth1
    NMI:          0          0          0          0
    LOC: 2203548572 2203548571 2203548570 2203548569
    ERR:          0
    MIS:          0
    host:/home/edge#
    
     

Share This Page