rspmd website not working

Discussion in 'Installation/Configuration' started by muekno, Apr 12, 2022.

  1. muekno

    muekno Member HowtoForge Supporter

    Would change to rspamd, followed https://www.howtoforge.com/replacing-amavisd-with-rspamd-in-ispconfig/#
    Everting seams to work fine, the server -> config -> mail shows what ist should like in the tutorial.
    But the website says not reachable.
    Server Debian 10 latest patches
    ISPConfig latest version
    System multiserver
    installed on mailserver which is secondary nameserver too.

    Regards Rainer
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    What do you mean with website? The Rspamd GUI as @Taleman guessed or a website on your server?
     
  4. muekno

    muekno Member HowtoForge Supporter

    I mean the Rspamd GUI
    Rechecked everything. the rspamd directories exist, the created/modified files looks fine comparing to the tutorial, the rspamd daemon ist running and listen on 172.0.0.1 on ports 11332 -11334, apache2 ist running, but nothing is listening on port 8081 as the URL shows under server -> config -> mail and on the screenshot in the tutorial. Using port 11334 as written in the tutorial does not work too. I access the the mailserver from the internal net, external access ist not needed. Updateing ISPConfig showed configuring rspamd.
    Remember the mail server is a slave server and I updated this one.
    Also I can not find something of rspamd under apache sites-availabel or sites-enabled.
    Regards Rainer

    P.S. the raoudcube on the server works
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Port 8081 is the apps vhost, which might need to be enabled for Apache (I think it normally is enabled in nginx). Be sure to allow access in your firewall as well.
     
  6. muekno

    muekno Member HowtoForge Supporter

    I am on the internal private network, no firewall involved. fuw firewall not installed.
    But I think I checked it, 127.0.0.1 is not accessable from my workstation. So I need the proxy.
    Sorry for asking
    Regards Rainer
     
  7. muekno

    muekno Member HowtoForge Supporter

    OK ist works, but I can access the dashboard only with http: whats not so severe as I am on my internal network. Also I can see amavis ist still active.
    Regards Rainer
    Is it correct that amavis still running?
     
    Last edited: Apr 12, 2022
  8. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    The how-to you followed included steps to disable amavis; you certainly don't need it running, and could even uninstall it to avoid later confusion.
     
  9. muekno

    muekno Member HowtoForge Supporter

    Thank you I stopped reading when I got the dashboard.
    Regards Rainer
     

Share This Page