rspamd users files created for -not enabled- spamfilter

Discussion in 'ISPConfig 3 Priority Support' started by KoS, Nov 25, 2019.

  1. KoS

    KoS Member HowtoForge Supporter

    As I still haven't had solved the issue in I noticed a strange behaviour.

    I have set for every domain the spam policy to "normal", and every user mailbox is set to "- not enabled-" (as it was with spamassasin). Whereas I can see in /etc/rspamd/local.d/users that EVERY user has a config file for his mailbox. If i set the mailbox policy to "normal" and back to "-not enabled-", then the file disappears. But if I use afterwars the resync tool, all the mailbox/user files get created again. Is this a bug or how can this behaviour be explained?

    If I want to have spam scanning enabled for a domain, is the correct setting that I enable it only for the domain (with "normal") and have the mailboxes set to ("- not enabled-")?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I'll discuss the behaviour with @Croydon to check if its intended ike this.

    Yes, that's fine. Not enabled means basically that it is not set for the mailbox so that the domain wide settings get applied.
  3. KoS

    KoS Member HowtoForge Supporter

    That was my understanding too, so that is why I was surprised with the above-mentioned behavior when re-syncing all services. Thanks for discussing with @Croydon
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Could you please check the "spamfilter user" section and look for the spamfilter user entries for both the address and the domain?
  5. KoS

    KoS Member HowtoForge Supporter

    • Mail Domain -> Spamfilter "Normal"
    • Spamfilter users -> There is only the entry for the above-mentioned domain, but no user-specific entries for that domain.
    I have now used the re-sync "all services" on that host and suddenly I get more or less for every user a file in /etc/rspamd/local.d/users/ :-(
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    That is normal behaviour. Rspamd cannot "override". The question is if the settings inside those files are correctly taken from the domain if the mailbox itself has no spamfilter setting.
  7. KoS

    KoS Member HowtoForge Supporter

    yes, the file for the domain itself ( with rcpt = has the same settings as the files for the single users, like with rcpt = [email protected]
    my understanding of the rspamd config system was that the domain file would be sufficient to cover all the users of the domain?
    and not that the config needs to be set per domain & per user (so it would just replicate the policy that is set in ispconfig on the domain level, and if the users mailbox has set "- not enabled-" it won't create any additional user conf files'

    how to you explain the logic that if I ENABLE for the user mailbox a Spamfilter and DISABLE it afterwards, = set to not enable, the users conf file gets deleted?

    and in addition, all the users of a domain are set to "not enabled" and I change the domain policy, then the users conf files do NOT get updated with the domain policy.
    Last edited: Nov 26, 2019
  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Sadly not. Rspamd stops at the first matching entry with highest prio. So it is not possible to lets say override the domain settings by adding a mailbox setting (spamfilter user) with lower priority as it was possible when using amavis.
    Because of we wanted the behaviour to be as consistent as possible between amavis and rspamd we decided to always write the user files.

    I will have to re-check that, but I think it depends. E. g. when "greylisting" is set to active, the file is absolutely required as it would not work otherwise.

    That should not be the case. Have you installed the latest version already? I'll have to re-check that then, too.
  9. KoS

    KoS Member HowtoForge Supporter

    Thanks for the info regards the first matching entry, I missed that part in the rspamd docu :-(
    Yes, I am using the latest version of ISPconfig, 3.1.15p2 on all servers.

Share This Page