rspamd on Debian 11

Discussion in 'Installation/Configuration' started by Stefan Schumacher, Mar 10, 2022.

Tags:
  1. Hi,
    I installed rspamd according to this manual - https://www.howtoforge.com/replacing-amavisd-with-rspamd-in-ispconfig/ - on a Proxmox KVM VM.
    During installation it asked if it could install the package hyperscan, which I confirmed. Nonetheless it outputs three errors on the shell, one of which is related to hyperscan. In which of the complex web of configuration files of rspamd do I disable hyperscan? I let the output speak for itself. I am rather sure its Debian 11 related since I did used the manual mentioned above just a few months ago on ISPConfig on Debian 10 and everything worked absolutely smoothly.

    Operating System: Debian 11.0 (Bullseye) or compatible
    Reconfigure Services? (yes,no,selected) [yes]: yes
    Configuring Rspamd
    chgrp: Zugriff auf '/etc/rspamd/local.d/worker-controller.inc' nicht möglich: Datei oder Verzeichnis nicht gefunden
    chmod: Zugriff auf '/etc/rspamd/local.d/worker-controller.inc' nicht möglich: Datei oder Verzeichnis nicht gefunden
    CPU doesn't have SSSE3 instructions set required for hyperscan, disable it
    Restarting services ...
    Update finished.

    Regards
    Stefan
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok and can be ignored.

    Seems as if you can disable that via Rspamd config file:

    https://github.com/hardware/mailserver/issues/282
     
  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

Share This Page