Rspamd GUI web it can't be found

Discussion in 'ISPConfig 3 Priority Support' started by Gaston Girardi, Aug 7, 2020.

  1. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Hi, i've change from Amavisd to Rspamd with the following tutorial:

    https://www.howtoforge.com/replacing-amavisd-with-rspamd-in-ispconfig/

    The only two difference i had it was with the Apache proxy module, when i run the command "a2enmod proxy" i get a response saying Module proxy already enabled, and the other is that i use my own domain for the https://rspamd.myowndomain.XXX/rspamd

    The thing is that when i try to run the Rspamd GUI page it doesn't open, i get the message that it can't find the page, what might i have done wrong?

    P.S.: I search on the logs for error, but i couldn't find anything :oops::confused:

    I'm using Debian 9 and Apache 2.4
     
    Last edited: Aug 10, 2020
  2. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Nobody has any idea?, as a comment i check the apache logs, access and error, the first one is empty and the second has this this messages but i don't know what they are:

    Code:
    [ 2020-08-09 22:28:02.0794 29138/7f6cfb6d9600 age/Wat/WatchdogMain.cpp:1291 ]: Starting Passenger watchdog...
    [ 2020-08-09 22:28:02.0840 29141/7f65c0776600 age/Cor/CoreMain.cpp:982 ]: Starting Passenger core...
    [ 2020-08-09 22:28:02.0841 29141/7f65c0776600 age/Cor/CoreMain.cpp:235 ]: Passenger core running in multi-application mode.
    [ 2020-08-09 22:28:02.1212 29141/7f65c0776600 age/Cor/CoreMain.cpp:732 ]: Passenger core online, PID 29141
    [ 2020-08-09 22:28:02.1276 29150/7fef433c4600 age/Ust/UstRouterMain.cpp:529 ]: Starting Passenger UstRouter...
    [ 2020-08-09 22:28:02.1280 29150/7fef433c4600 age/Ust/UstRouterMain.cpp:342 ]: Passenger UstRouter online, PID 29150
    [ 2020-08-09 22:28:02.1350 29099/7f16617d6600 age/Cor/CoreMain.cpp:967 ]: Passenger core shutdown finished
    [Sun Aug 09 22:28:02.151951 2020] [:error] [pid 29135] python_init: Python version mismatch, expected '2.7.5+', found '2.7.13'.
    [Sun Aug 09 22:28:02.152010 2020] [:error] [pid 29135] python_init: Python executable found '/usr/local/bin/python'.
    [Sun Aug 09 22:28:02.152013 2020] [:error] [pid 29135] python_init: Python path being used '/usr/local/lib/python2.7:/usr/local/lib/python2.7/plat-x86_64-linux-gnu:/usr/local/lib/python2.7/lib-tk:/usr/local/lib/python2.7/lib-old:/usr/local/lib/python2.7/lib-dynload'.
    [Sun Aug 09 22:28:02.152024 2020] [:notice] [pid 29135] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Sun Aug 09 22:28:02.152027 2020] [:notice] [pid 29135] mod_python: using mutex_directory /tmp
    [Sun Aug 09 22:28:02.167423 2020] [mpm_prefork:notice] [pid 29135] AH00163: Apache/2.4.25 (Debian) mod_fcgid/2.3.9 Phusion_Passenger/5.0.30 mod_python/3.3.1 Python/2.7.13 OpenSSL/1.0.2u configured -- resuming normal operations
    [Sun Aug 09 22:28:02.167449 2020] [core:notice] [pid 29135] AH00094: Command line: '/usr/sbin/apache2'
    
    Hope anyone can help me.

    Best Regards.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you create a dns a-record for the rpsamd subdomain and point it to the server?
     
  4. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Hi Till, yes i did create it in the domain an A record pointing to the main IP of my server, that didn't work so I erase it. I create a Zone and the same, i don't know how many time i try it.

    Thinking more clearly what i never did it was wait a couple of hours.
     
  5. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    Create that again and give it 24-72 hours to propagate.
     
    Gaston Girardi likes this.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    And ensure that you create it on the DNS server that is authoritative for the domain, this is not necessarily your ISPConfig server, it can also be the DNS server at the company where you registered your domain or your hosting provider.
     
    Gaston Girardi likes this.
  7. Gaston Girardi

    Gaston Girardi Member HowtoForge Supporter

    Finally it is working, beside the fact that you need the A record on the DNS, also need to wait a couple of hours at least, i know sometime DNS record can be reflected immediately, but others take time and being desperate is not good.

    And I had another error, 404, but it was with the SSL certificated and i solved it quickly.

    Thanks you all.
     
    till and Th0m like this.

Share This Page