rpmbuild -ta courier-imap-4.4.1.tar.bz2 fails

Discussion in 'Installation/Configuration' started by joek168, Jan 30, 2009.

  1. joek168

    joek168 New Member

    Hello,

    I'm trying to install on a CentOS 5.2 64 bit machine. Everything goes fine until the following:

    rpmbuild -ta courier-imap-4.4.1.tar.bz2

    I get the following error, which occurs when it seems to be testing protocols:

    INFO: LOGOUT, user=user1, ip=[127.0.0.1], headers=0, body=0, rcvd=464, sent=2582, time=0
    INFO: LOGIN, user=user1, ip=[127.0.0.1], port=[0], protocol=IMAP
    INFO: LOGOUT, user=user1, ip=[127.0.0.1], headers=0, body=0, rcvd=404, sent=1888, time=0
    LC_ALL=C; export LC_ALL; test "yes" = "yes" || exit 0; /bin/sh ./smaptestsuite | ./testsuitefix.pl | sort | cmp -s - ./smaptestsuite.txt
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=65, sent=3023, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=44, sent=175, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=1179, body=461, rcvd=565, sent=3171, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=18, body=5962, rcvd=665, sent=7684, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=164, sent=62284, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=2346, sent=11641, time=1
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=1118, sent=3765, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=124, sent=564, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=20, sent=110, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=161, sent=671, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=308, sent=1453, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=28, sent=128, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=1195, body=0, rcvd=355, sent=2038, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=379, sent=1305, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=318, sent=1067, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=45, sent=167, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=IMAP
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=81, sent=824, time=0
    INFO: LOGIN, user=compileuser, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=compileuser, ip=[127.0.0.1], headers=0, body=0, rcvd=140, sent=480, time=0
    INFO: LOGIN, user=confmdtest, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=confmdtest, ip=[127.0.0.1], headers=0, body=0, rcvd=2491, sent=6204, time=0
    INFO: LOGIN, user=confmdtest, ip=[127.0.0.1], port=[0], protocol=SMAP1
    INFO: LOGOUT, user=confmdtest, ip=[127.0.0.1], headers=0, body=0, rcvd=26, sent=610, time=0
    make[2]: *** [check-am] Error 1
    make[2]: Leaving directory `/home/compileuser/rpm/BUILD/courier-imap-4.4.1/imap'
    make[1]: *** [check] Error 2
    make[1]: Leaving directory `/home/compileuser/rpm/BUILD/courier-imap-4.4.1/imap'
    make: *** [check-recursive] Error 1
    error: Bad exit status from /var/tmp/rpm-tmp.43200 (%build)


    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.43200 (%build)

    Any ideas how to fix, I searched the net and couldn't find any good resources.

    Any help would be greatly appreciated!

    Thanks,

    Joe
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. joek168

    joek168 New Member

    Same error

    Got the same error with that file.

    Thanks,

    Joe
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you install these before?
    Code:
    yum groupinstall 'Development Tools' 
    yum groupinstall 'Development Libraries'
     
  5. joek168

    joek168 New Member

    yes

    both installed...
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Not sure what's wrong. Maybe some 64bit-specific package is missing and needs to be installed? :confused:
     
  7. vman

    vman New Member

    hiya, did you ever find a solution to this problem or a possible workaround?
     
  8. joek168

    joek168 New Member

    no, we decided to install different software instead.

    jk
     
  9. vman

    vman New Member

  10. joek168

    joek168 New Member

    we went with webmin/virtualmin. Been working great, so far.

    Thanks,

    Joe
     

Share This Page