rpm build ERROR!! with Fedora 12 - Perfect server ISPConfig3

Discussion in 'HOWTO-Related Questions' started by j.smith19810808, Mar 2, 2010.

  1. j.smith19810808

    j.smith19810808 New Member

    I am having grave problems doing the rpmbuild in the above howto, concerning courier-imap-4.6.0-1.12.i686.rpm.

    It keeps bringing up the following error response:

    Whats going wrong here? I have tried making sure the folders for compileuser are world writable (not the best way of doing things but just to see if it was that, still wont work), its got to be the way its building the rpm, thats all I say.

    I have given up for now as I have attempted this 5 times now, same response each time, must be an error in the way the files are on this server.

    Can someone come up with a way of getting around this please?

  2. merisor

    merisor New Member

    Probably the user "compileuser" doesn't have write permission to those folders. You should try, as root, something like:

    chmod -R compileuser /home/compileuser/rpm/RPMS
    chmod -R compileuser /home/compileuser/rpm/SRPMS
  3. j.smith19810808

    j.smith19810808 New Member

    I already did that, still no luck.

    I have ispconfig2 working anyways.

    Whats the security problem with just going with ispconfig2, just out of curiosity?

    Something thats been bugging me a bit when I managed to get the mail server working and http working.

    I decided to use https but everytime I accidentally go to http://mydomain.com it brings up a bad request, thats fine!

    But its bringing up my hostname (of my machine on my LAN), ie server1.jeremysmith.me.uk, I want it to use www. and not server1.jeremysmith.me.uk

    How do I go about changing this?

    Can someone help?

    Once I have this working, also I wondered if I can completely change this? Like instead of it going to www.jeremysmith.me.uk, is there any way of making it go to an address like: www.mydomain.com (any i have as a public domain on the Internet?)

    Any help is greatly appreciated.

    I now have it working with Outlook aswell thats wonderful!
  4. falko

    falko Super Moderator ISPConfig Developer

    You can run
    to change the hostname.
  5. j.smith19810808

    j.smith19810808 New Member

    This is from apache isnt it?

    Where its getting the hostname from?

    Should be able to change that in apache, I will have a play about with it when I get to version 3 of ispconfig.

    The problem is, with chown it doesnt work, the username and group to all folders in /home/compileuser no other user so thats effectively pointless!

    I have even tried making it world writable (not generally very secure but since this isnt available on other nodes other than what I specify in hosts.allow and changing the sshd port to something random that I can remember, its fine, havent had any even attempts to hack into my server).

    Still comes up with the same error.

    I will try going over it again though.
  6. j.smith19810808

    j.smith19810808 New Member

    No it hasnt worked.

    I think I am going to give up unless someone has the same problem, its just not working for me.

    Still giving the same exact error as before, its really frustrating this, was working previously, havent done any changes and this is the 4th attempt, the same thing copied line by line within commands and nothing seems to be happening thats any different to the last time.

    I dont know what to do, any other suggestions?

    I really am getting quite frustrated with this.

    Thanks though for your help, any advice will be appreciated though.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Why shall there be a security problem. ISPConfig 2 and 3 are independant software packages, they are both stable and ispconfig 3 is not an update for ispconfig 2, its a completely different software for multiserver setups.
  8. j.smith19810808

    j.smith19810808 New Member

    I am requiring some features from FC12, I dont have a decent enough computer for a 64bit system though.

    Could you make a 32 bit version of that tutorial?

    I just cant get this to work, perhaps it is because I am running a 32bit system and the tutorial is 64bit, yet I go to FC10 of the same tutorial and non of the tar.gz packages are available.

    I would really appreciate this as ISPconfig has some features I would really want to use, dont really have any use for ISPconfig 2 unfortunately, since I got that working, just wanted to see if it would work thats all.

    I then cleared out my system and have all necessary packages for a full install of ISPconfig 3 on FC12 32bit so I would greatly appreciate a tutorial for the 32bit equivalent.

    I look forward to some reply,
  9. deroozano

    deroozano New Member

    After browsing on uncle google :), I found the solution...

    Change owner of the folder:

    sudo chown username /home/username/path to where the rpm build will be located (/home/username/rpm/RPMS/I586) * please not this is where my directory where my output rpmbuild are, and its i586 not i386 yours could be different*

    after that then go to the directory where you have the downloads in and run rpmbuild again *without using root or sudo command or it will fail*

    *command to build the rpm*
    rpmbuild -ta courier-imap-4.6.0.tar.bz2

    And It works
  10. j.smith19810808

    j.smith19810808 New Member

    To be honest, I am now using Centos 4.8.

    Just incase anything else crops up but thanks for that help, if I ever get sick of the lack of things that arent available in centos as compared to Fedora then I will come back to this help.

    Thanks for your reply, this could help others.

    Kind regards as always,
  11. Tyshalle

    Tyshalle New Member


    I am having similar build problems with 'rpmbuild -ta courier-imap-4.6.0.tar.bz2'

    I tried doing what you suggested, but I keep getting this

    [Eddie@Eddie downloads]$ sudo chown /home/Eddie/rpm/RPMS/i686/
    chown: missing operand after `/home/Eddie/rpm/RPMS/i686/'
    Try `chown --help' for more information.
    [Eddie@Eddie downloads]$

    also tried

    [Eddie@Eddie downloads]$ sudo chown -h /home/Eddie/rpm/RPMS/i686/
    chown: missing operand after `/home/Eddie/rpm/RPMS/i686/'
    Try `chown --help' for more information.
    [Eddie@Eddie downloads]$

    am I just doing it wrong?

    thanks in advanced

    edit: fixed it... realized what I was doing wrong
    Last edited: Mar 25, 2010
  12. robertlouwen

    robertlouwen New Member

    Hello Tyshalle,

    I had the same problem with courier-imap.
    Here is what I did:

    As a brainless person I copy and paste this:
    mkdir $HOME/rpm
    mkdir $HOME/rpm/SOURCES
    mkdir $HOME/rpm/SPECS
    mkdir $HOME/rpm/BUILD
    mkdir $HOME/rpm/BUILDROOT
    mkdir $HOME/rpm/SRPMS
    mkdir $HOME/rpm/RPMS
    mkdir $HOME/rpm/RPMS/i386
    When building courier-imap in want to write to a folder that is not created by compileuser.

    So instead of
    mkdir $HOME/rpm/RPMS/i386
    I did
    mkdir $HOME/rpm/RPMS/i686
    and it worked for me. ( I know it seems to be obvious and stupid, but it really worked for me )

Share This Page