Router hates linux hosts

Discussion in 'Technical' started by timaaarrreee, Aug 14, 2008.

  1. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    Hi all,

    Is there a way i can configure my servers hosts file to get my router to show up the hosts so i can find out whos who and so that my port fowarding issues can be resulved?:confused:

  2. falko

    falko Super Moderator ISPConfig Developer

    What exactly is the problem?
  3. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    well when i port foward ports like 80, 21, 53 etc my router can't display the hostnames of my linux servers properly. Unlike windows comps that show the computer name ans the hostname. And with this problem it makes it difficult to foward the right ports to the right server. i was woundering if i can edit the host files or something to make it look like a windows host name.
  4. planet_fox

    planet_fox Member HowtoForge Supporter

    whats is your router
  5. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    its a D-Link DSL-G604T I actuly might ask d-link about this on their support site
  6. brainz

    brainz Member

    This router does not support NAT Local Loopback.....

    brainz ;)
  7. bad_crow

    bad_crow New Member

    Try to activate netbios on your linux box, most of the time the computer's name is obtained by netbios when on a network without DNS server.

    You may also be able to setup a DNS and to get host name from IP and the contrary, but I don't think this will show up in your router.

    Other way to do so, give the same IP to the same host each time via DHCP with the NIC mac address, most of the routers are able to do it. That way you keep your setting in mind and you won't have to seek who is who. I you are lucky, this will even show the names up on your router, but this doesn't work with my netgear so...

    Can you explane your forwarding problem and why you wan't it ? Maybe we can help on this.

Share This Page