rounducubemail issues - redirecting to /mail

Discussion in 'Installation/Configuration' started by Amorphous, Dec 22, 2011.

  1. Amorphous

    Amorphous New Member

    Hello again!

    Allthough i have searched the entyre forum for this problem i havent found anything, if you have the response for my problem, please just link to it !

    i have ISPConfig installed, everything is ok, just one issue with one of the settings inside the vhosts:

    i have installed Roundcubemail the version is not important because a had the same problem with 3 different versions.

    i have created a website and manually adjusted the path to go to /usr/share/roundcubemail.

    i had to comment this line inside the vhost settings in order to make roundcube interface to work:

    #php_admin_value open_basedir /home/www/clients/client4/web24/web:/home/www/clients/client4/web24/tmp:/home/www/

    i have followed some of the steps from here - - in order to create an alias /mail for roundcube ( i want to use also /webmail (squirrelmail) in the same time )

    for a website that has the above line commented out, the alias /mail is working; if not, i get :

    You don't have permission to access /mail/ on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    as an example: - gets the above error, because of the mod-php line not commented out.

    is there a way i can stop for good that line for being active insinde newly created websites, and if it`s stopped, ( i might know how to disable it from ISPConfig interface - System -> server config -> web -> PHP openbase_dir line ) could some php scripts, CMS, etc.. not work anymore ?

    Thank you !
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not use /mail as alias for webmail or parts of the ispconfig interface will become inacessible as the mail module in ispconfig is in the directory /mail. Chnage the alias to e.g. /webmail.

    To your roundcube installation issue, by commenting out the open_baesdir directive you opend u a security hole on your server. If you like to install roundcube in a website, then install roundcube in that website and not in /usr/share/roundcubemail
  3. Amorphous

    Amorphous New Member

    thank you Till, i will try to make the necesary changes ...

    in the meantime, as long as my clients will still try to use the mail system , is there a possibility to make a automatic creation of the folder /mail ( with a preinstalled copy of roundcube inside the websites) , together with the other precreated files ? ( stats, error etc .... )
    so each website created should have allready implemented the roundcube mail system ??

    maybe it s crazy what i am trying to do, but it s worth a try :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    you can write a ispconfig plugin which is executed after the website is created to do something like that. But personally I wont do that.

    If I were you I would just modify the .htaccess file template in /usr/local/ispconfig/server/conf/index/ and add a rewrite rule there that redirects users from /mail to /webmail or to a custom url where you installed roundcube.
  5. Amorphous

    Amorphous New Member

    Thank you Till !

    problema solved .....

    created a new alias /email for roundcube, /webmail still working for squirrelmail.

    installed roundcube in a newly created website, with all the php rules actives. the /email alias redirects to that website, everything is ok :)

    Merry Christmass !!

Share This Page