RoundCube

Discussion in 'Feature Requests' started by nveid, Jan 16, 2006.

  1. till

    till Super Moderator

    As far as i know, roundcube is still in alpha state, so dont expect all functions to work.
     
  2. CyberCam

    CyberCam New Member

    ok I'll continue to use uebimiau webmail client until this is up to par. Thanks!
     
  3. Hans

    Hans Moderator

    Good experience with RoundCube!

    I have RoundCube up and running here on my “Perfect Debian Sarge system” and looks very nice!
    The last couple of weeks I have tried Horde & Squirrelmail, because the Uebimiau project looks very dead. Although RoundCube is still in Beta, it looks very good with an active community as well.
    At the moment, I have Roundcube running parallel with Uebimiau, but when there is a stable version available, I switch over! So I made my choice!

    What I did was the following:
    I created a website within ISPConfig with SSL and MySQL enabled.
    I downloaded RoundCube within this website and extracted it.
    Changed the filenames db.inc.php.dist into db.inc.php and main.inc.php.dist in main.inc.php
    I changed the timezone, login, password and databasename within the file db.inc.php as described here:
    http://www.paulstamatiou.com/2005/10/29/how-to-setup-roundcube-webmail-on-your-server/
    I created a new main.inc.php file for ISPConfig according paulrobert_a ‘s instruction in this thread.

    There is a possiblility to login with username@domain.tld and only username without @domain.tld as well.

    I had a problem within Roundcube (wrong timestamps for the e-mails), but in the meantime that is solved.

    Tip: within the latest CVS version, there are more languages and themes available.

    Although Roundcube has nothing to do with ISPConfig, also here is the username@www.domain.com problem. (The identity of the mailboxuser is not username@domain.tld as it should be).
    Maybe Roundcube copies the name@www.domain.tld identity from the server somehow.

    If they add more functionality/stability, Roundcube has a great future!

    Hans
     
    Last edited: May 4, 2006
  4. till

    till Super Moderator

    Seems as the UebiMiau project has awakened again :)

    http://www.uebimiau.org/
     
  5. Hans

    Hans Moderator

    Uebimiau

    That’s good to know Till, I hope the community will survive, because it is a nice webmail.
    By the way, I have a small problem with Uebimiau, the timestamps of the e-mails are 1 hour to early. I have decribed it here:

    Is there a solution for this?

    Hans
     
  6. falko

    falko Super Moderator

  7. Hans

    Hans Moderator

    Falko,

    thanks for your reply, but i have that 64 bit fix already installed.
    That fixes the notation on 64 bit systems.

    I do not know why the timestamps are 1 hour to early yet but i hope i will find out soon.

    Hans
     
  8. edge

    edge HowtoForge Supporter

    Hans,

    Did you / anyone ever find a fix for this?

    I can change the name@www.domain.tld to name@domain.tld within roundcubemai > Personal Settings > Identities , but as soon as I logout, and back in again it's back to name@www.domain.tld!
     
  9. jnolla

    jnolla New Member

    Not receiving

    Installed through the Tool in Ispconfig, but can't receive? I can send!

    Any help?
     
  10. falko

    falko Super Moderator

    Only with Roundcube? Can you recieve emails with a normal email client like Thunderbird or Outlook?
     
  11. firthusa

    firthusa New Member

    Cannot Login to RoundCube

    I installed RoundCube through the Update feature and it seemed to install fine. I created some email accounts and went to tools and clicked on the RoundCube button however I cannot login. In fact it just sits there spinning and eventually times out. It does this on both IE & FireFox and neither give me any errors... they just sit there and spin. I'm running a fresh install of Debian following the tutorials on this site. Any advice would be greatly appreciated.
     
  12. till

    till Super Moderator

    Any error messages in the mail.log?

    Did you try the username and the email address for login?
     
  13. botum

    botum New Member

    You can solve this by sending a first email to the account, so the folder INBOX will be created.

    Then you might have problems with Trash folder...

    I solved the trash problem (standalone roundcube, not with ISPC) whith this patch.

    http://trac.roundcube.net/trac.cgi/ticket/1471594
     
  14. jockstrap

    jockstrap New Member

    I had 2 problems after my install;

    1) could not move files to trash - the code fix link posted by BOTUM above fixed that.

    2) was putting a www. infront of the domain when sending emails. You could change this in preferences but when you logged back in it reverted back. This is fixed if you login as the real userid - ie: web1_username instead of using the email address to login with. Well, seems to work ok for me anyway.
     
    Last edited: Jul 8, 2006
  15. danbogos

    danbogos New Member

    Temporary FIX for www. problem

    I have gone thru all the problems you were getting, with no automatic folders creation, and the biggest, which was non acceptable for my users, the www which was keep coming in contact info.

    I will describe here my workarround, so at least you should not spend the same time which I did on it.

    The problem comes from Round Cube, which is looking into the mail server alias file (my case postfix). There, ISPConfig has set up the first alias prefixed with www, as your default host name was configured.
    Now, everytime when you will log in without www user@domain.com, RoundCube will assume that you are a new user, and will open a new account in it's database (all the user settings are automatically saved in RoundCube database). If you will try loggin in with user@www.domain.com, you will see that the settings for contact will be saved and next time you will log in , you will have the same thing. Moreover, everytime you will log in with different aliases, you will get different settings saved for each of them :).
    After I digged through ISPConfig forum, I found out that the problem with aliases will be there till some next release, where you will be able to select your aliases type (with or without hostname). Then, our problems will be completed sort out.
    Till then, what you can do, and what I did, was, creating a separate aliases file, only for rouncube, where you will put the usernames, exactly in the way you need them.
    Ex of entry in roundcube_alias
    user@domain.com web1_user
    After you will have the file, you should change the value of $rcmail_config['virtuser_file'] in /home/admispconfig/ispconfig/web/roundcubemail/config/main.inc.php.
    The only problem which you will still have, it will be adding one new alias for each user newly created on your system. The advantage is that you can have users with pop3/imap and users with webmail access ;).
    If I was not clear enough, I am available for questions.

    Cheers,
    Dan
     
  16. wr19026

    wr19026 New Member

    Can anyone tell me if (and how) the problem with RoundCube (installed from the pkg) not saving preferences is fixed?
     
  17. falko

    falko Super Moderator

  18. wr19026

    wr19026 New Member

    I have and it's not real easy to understand (for me anyway :)) So as much as I'd like to be able to use RoundCube, I guess that UebiMiau is my webmail client of choice for now.

    Having said that, does anyone have a more recent version of UebiMiau in pkg format? My understanding is that UM now also supports IMAP which I'm really looking for.

    I've seen the thread on UM updates but no follow up (as in Ï have done it and you can get the package here") ....
     
    Last edited: Jul 12, 2006
  19. jockstrap

    jockstrap New Member

    Hi - as my post above says...

    Preferences for me ARE being saved if users login with their system user name and NOT their email address..

    In ispconfig - I opted to remove the webx_ userid prefix. so each user gets a username like joesmith...

    If they log into roundcube with "joesmith" and NOT "joesmith@domain" then everything is fine with saving preferences.

    I have not setup many users yet, so try it and see if it works ok for you...

    The only problem I seeming to have now is that AUTORESPONDER is not working properly. It chooes to work one or twice then stop ???? seems it may be sending the response to admispconfig@localhost but not sure why yet!
     
  20. till

    till Super Moderator

    I guess you tested the autoresponder several times from your account? The aotoresponder stores the email addresses where it sends the message so every account will get the message only one time to avaoid message loops.

    That is not the autoresponder message, the messages to admispconfig are for statistic generation, dont try to redirect these messages to another account!
     

Share This Page