roundcube works but outlook does not

Discussion in 'Installation/Configuration' started by ariban99, Jul 5, 2015.

  1. ariban99

    ariban99 Member

    I installed the server with apache2 following this
    everything is working really great. however because i am running my server on comcast residential isp, i had to change the configuration in roundcube to use comcast relayhosts.
    so now roundcube works great and i can send emails.
    however when i go into outlook and i try to send emails it wont work unless i also put the smtp of comcast relay in there but i dont want to do that as its my laptop and when i travel and i am not on comcast internet connection those relay hosts options wont work.
    is there a way to setup an email client that it will connect to the server and whatever is already set in the server configuration as a relay through comcast that should work without having to put those setting also in outlook? someone posted to try this

    nano /etc/postfix/
    relayhost = []:587
    smtp_sasl_auth_enable = yes
    smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
    smtp_sasl_security_options =

    save and close file

    nano /etc/postfix/sasl_passwd comcastuser:comcastpassword

    save and close

    chown root:root /etc/postfix/sasl_passwd
    chmod 600 /etc/postfix/sasl_passwd
    postmap /etc/postfix/sasl_passwd
    postfix reload

    so i tried this but it still doesnt work? what can i do?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    the relayhost in a ISPConfig server is set in ISPConfig under System > Server config > mail. There is no editing of config files required, doing it anyway might cause the setup to fail as your manual changes conflict with ispconfig now.
  3. ariban99

    ariban99 Member

    i did that and i get the following error when sending in outlook:
    Your message did not reach some or all of the intended recipients.
    Subject: send test
    Sent: 7/5/2015 1:15 PM

    The following recipient(s) cannot be reached:
    '[email protected]' on 7/5/2015 1:15 PM
    Server error: '454 4.7.1 <[email protected]>: Relay access denied'

    can it be that because port 25 is blocked i am getting this message? is there a way to change the outgoing port to another port number like 2626 instead of 25 that outlook should use to connect to my server? then my server will send the actual email over the relayhost and their port??

    thank you
  4. ariban99

    ariban99 Member

    i also get this email came in saying bad header:

    The message WAS NOT relayed to:

    <[email protected]>:

    554 5.6.0 bounce, id=05912-02 - bad header

    This nondelivery report was generated by the program amavisd-new at host Our internal reference code for your message is 05912-02/ni_Qy1-b2xsW


    Missing required header field: "Date"

    Return-Path: <[email protected]>

    From: Microsoft Outlook <[email protected]>

    Subject: Microsoft Outlook Test Message

    when i click on the details attachment it says:

    Reporting-MTA: dns;
    Received-From-MTA: dns; ([])
    Arrival-Date: Sun, 5 Jul 2015 13:16:50 -0400 (EDT)

    Original-Recipient: rfc822;[email protected]
    Final-Recipient: rfc822;[email protected]
    Action: failed
    Status: 5.6.0
    Diagnostic-Code: smtp; 554 5.6.0 Bounce, id=05912-02 - BAD HEADER
    Last-Attempt-Date: Sun, 5 Jul 2015 13:16:50 -0400 (EDT)
    Final-Log-ID: 05912-02/ni_Qy1-b2xsW
  5. ariban99

    ariban99 Member

    anyone has a way to fix this?
  6. ariban99

    ariban99 Member

    i fixed this by opening another port on my firewall and forwarding that port to port 25, so it bypasses the block on port 25

Share This Page