Roundcube with Courier - So slow Help

Discussion in 'HOWTO-Related Questions' started by James A, Dec 29, 2011.

  1. James A

    James A Member HowtoForge Supporter


    We set up the perfect server following with the change that we used roundcube rather than squirrel mail. This was done over a year ago and since then we have always suffered with roundcube being really slow when a user has more than 1000 emails in their inbox.

    This is now becoming a big issue as more users are going for webmail. I have read that it may be due to server side sorting through courier although I don't know how to change the courier config to disable this (not even sure where it is, I'm new to this part).

    Any advice would be appreciated. Also these servers are live so I'm looking for a fix, nothing too radical. I'm running .7 for roundcube and not sure on the courier version (where can I find it?)

    Thanks in advance
  2. James A

    James A Member HowtoForge Supporter

    Right, digging a little further and I have found the option to disable server side sorting IMAP_DISABLETHREADSORT which I have now set to 1 (etc/courier/imapd). This appears to have made some difference with loading times for a 700 email inbox going from roughly 25 sec to about 15. As roundcube is hosted on the same server I guess I'm pushing it to expect any greater an improvement with that change.

    One other thing I had read was it may have something to do with IPv6, does that sound like a posibility or is that really barcking up the wrong tree?
  3. James A

    James A Member HowtoForge Supporter

    Right, switching off sorting from the roundcube user interface dramatically improves speed for the user. It basically brings it to a level I would expect. The question is, given that roundcube is supposed to create a cached copy why would it take so long to sort these mails by date etc.

    Once again, any help would be appreciated.
  4. Gigaquad

    Gigaquad New Member

Share This Page