Roundcube with API plugins: "Soap Error: Could not connect to host"

Discussion in 'ISPConfig 3 Priority Support' started by mircsicz, Oct 14, 2015.

  1. mircsicz

    mircsicz New Member HowtoForge Supporter

    Hi hi,
    I've setup Roundcube on one of my ISPconfig controlled server's according to this howto: https://www.howtoforge.com/tutorial/roundcube-installation-on-debian-8-jessie/

    After the line:
    there should be mentioned that the config has to go to the other "ispconfig_*" folder's too!

    But besides that I can't connect anyways...

    I'm using a multidomain cert, so running:
    Code:
    openssl x509 -in /usr/local/share/ca-certificates/ispserver.crt -text -noout | grep Subject:
    leaves me with:
    Code:
    Subject: OU=*MYCERTID*, OU=See www.rapidssl.com/resources/cps (c)15, OU=Domain Control Validated - RapidSSL(R), CN=*.mydomain.de
    So I can't follow this directly:
    So I created a "/etc/hosts" entry:
    Code:
    127.0.0.1 mydomain.de
    and changed the url in the "ispconfig3_*/config/config.inc.php" from "websrv0x.mydomain.de" to "mydomain.de" but I still get that Soap Error...

    Hope you can help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just edit the file ispconfig3_account/config/config.inc.php file, there are no other files to be edited. You can also see that in the installation guide of the plugin. https://github.com/w2c/ispconfig3_roundcube/wiki/Installation-Instructions-(manual)

    That's ok and no need to edit the hosts file, the step is only nescessary for self signed ssl certs.
     
  3. mircsicz

    mircsicz New Member HowtoForge Supporter

    THX Till,
    checked the doku, deleted and reinstalled the plugins from the master.zip and used the server-IP this time. But I still get the same error...

    Do I need to enable the API?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, the api is always available. You just have to add a remote user. Try to copy the api URL from the config file and open it in a browser, you should see a white page and not an error. You can also try to access it from the shell e.g. by wget or lynx to see if there is a connectivity error when accessed from the server itself.
     
  5. mircsicz

    mircsicz New Member HowtoForge Supporter

    I've already checked with Chrome (which is as expected) and curl from the server console (curl only works with the -k or --insecure Param) and give's simply no feedback on console.

    The user is there for sure! So what's next?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    If the insecure param is needed then your system does not know that the ssl authority is valid. Try to import the intermediate cert into the linux cert store and add it to the php.ini.
     
  7. mircsicz

    mircsicz New Member HowtoForge Supporter

    I've already done that by running:
    Code:
    cp /usr/local/ispconfig/interface/ssl/ispserver.crt /usr/local/share/ca-certificates/
    update-ca-certificates
     
  8. mircsicz

    mircsicz New Member HowtoForge Supporter

    I've already run:
    Code:
    cp /usr/local/ispconfig/interface/ssl/ispserver.crt /usr/local/share/ca-certificates/
    update-ca-certificates
    
    and added this line:
    Code:
    openssl.cafile=/etc/ssl/certs/ca-certificates.crt
    to "/etc/php5/fpm/php.ini" and restarted php5-fpm

    and just ran update-ca-certificates again, but the error remains... And checked if /usr/local/ispconfig/interface/ssl/ispserver.crt is part of /etc/ssl/certs/ca-certificates.crt which it is...
     
    Last edited: Oct 14, 2015

Share This Page