Roundcube times out

Discussion in 'Installation/Configuration' started by bswinnerton, Oct 29, 2008.

  1. bswinnerton

    bswinnerton New Member

    Don't know the reason, but since today when I go to my roundcube address I can see everything normal, but when I go to login it just says waiting for domain.com. And then it will finally display a blank screen.

    Looking in the logs I see:

    PHP Fatal error: Maximum execution time of 120 seconds exceeded

    How can I fix this?
     
  2. bswinnerton

    bswinnerton New Member

    I realized what I did, I accidentally changed the permissions of my Maildir folder. What should the correct permissions be?
     
  3. bswinnerton

    bswinnerton New Member

    Is there any way to have ISPConfig correct all of the permissions for my users? I made a very stupid move and did a recursive change. I'm not sure if it was the permissions that were changed or the owner. And i'm not sure of what the correct settings should be.
     
  4. bswinnerton

    bswinnerton New Member

    Problem Resolved, just changed one of the settings for one of my users and ISPConfig fixed my permissions.

    Once again, ISPConfig has saved my ass! =)
     
  5. hambuergaer

    hambuergaer New Member

    Hi bswinnerton, I`ve got the same problem. What did you change for your users? I have the same problem, that for all my webs and the mail users roundcube shows a blank screen after the login :-(
     
  6. bswinnerton

    bswinnerton New Member

    Hmm, i think we may have different problems. Mine just would time out and stay at the login screen. But just for kicks, what I did to fix my problem was went into one of the users. Turned off spam checking and then clicked the recycling bin, waited for it to say updating configuration files, and when it was I just went and turned it back on which fixed it.
     
  7. hambuergaer

    hambuergaer New Member

    Ok, this is strange! Unfortunately this do not work for me :-( How do you login? With web1_username for example?
     
  8. bswinnerton

    bswinnerton New Member

    No, I usually login with user@domain.com. Or if you have it in your roundcube configuration file you can configure it for just "user"
     
  9. hambuergaer

    hambuergaer New Member

    Where can I configure it? If I login at ISPConfig as admin I can just cick under "Tools" the option Roundcube. But this is just the Roundcube login page...
     
  10. bswinnerton

    bswinnerton New Member

    in /roundcube/config/main.inc.php

    Code:
    / Automatically add this domain to user names for login
    // Only for IMAP servers that require full e-mail addresses for login
    // Specify an array with 'host' => 'domain' values to support multiple hosts
    $rcmail_config['username_domain'] = 'ENTER HERE';
    
     
  11. hambuergaer

    hambuergaer New Member

    I feel sorry for my stupid questions, but what do I have to enter there, if I want to login with user@domain.de?

    AND THANK YOU FOR YOUR FAST ANSWERS!!!!!
     
  12. bswinnerton

    bswinnerton New Member

    Don't worry! It's not a stupid question at all. You would enter domain.de there.
     
  13. hambuergaer

    hambuergaer New Member

    Ok, one last question. If I install the Roundcube *.pkg file with the Update function in ISPConfig do I need a roundcoube config folder in every web? My server is a multiweb hosting server and I need roundcube for every web!

    But the only main.inc.php I found on my server is in /home/admispconfig/ispconfig/web/roundcubemail/config. This is the standard install directory of ispconfig...

    Do I need the roundcube config folder in every of my webs?
     
  14. bswinnerton

    bswinnerton New Member

    I'm not sure to be honest. I usually install roundcube in only one of my webs (For example the master) And then if you set it up to look at your virtusertables you can have every domain log into it on that one domain. The only thing is that they have to type the full email address. However, yes if you were to put a roundcube installation in every web, and then configure the main.inc.php as i showed above, they wouldn't only have to type user instead of user@domain.de
     
  15. hambuergaer

    hambuergaer New Member

    I found the mistake. I forgot to set the option "Maildir" in ISPConfig under Management => Server => Properties => EMail .... Thats all.... Aaaarrrrggghhhhhh ;-) Thank you for your help!!!!!
     

Share This Page