Roundcube SSL/TLS Auth

Discussion in 'General' started by Donno, Jan 21, 2019.

  1. Donno

    Donno Member

    Some clients are not able to send email to gmail. Using outlook with SSL and SPA the emails go through using roundcube it does not.
    My setup :
    i have domain example.com
    Created sub domain mail.example.com with ssl
    Setup roundcube IMAP to use ssl://mail.example.com
    SMTP to use tls://mail.example.com

    this works fine now for cert since i have crt in ../ssl/mail.example.com.crt i setup :
    $config['smtp_conn_options'] = array(
    'ssl' => array(
    'verify_peer' => true,
    'verify_depth' => 3,
    'cafile' => '../ssl/mail.example.com.crt',
    ),
    );

    This gives me error SMTP Auth Error 220 in logs it looks like this :

    ERROR: STARTTLS failed ()
    ERROR: Invalid response code received from server (-1)
    ERROR: Invalid response code received from server (-1)

    Any help ?
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    CA = certificate authority, but you set that to the certificate file itself; is this a self signed certificate? If so, try setting
    'allow_self_signed' => true
     
  3. Donno

    Donno Member

    No, its from let's encrypt seems like i do not have permission but cannot get it to work.
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    The certificate file with your server's letsencrypt certificate does not contain the CA certificate nor intermediary certificates; try setting cafile to /etc/ssl/certs/ca-certificates.crt (or wherever your system puts it, that works for debian/ubuntu).
     

Share This Page