Roundcube Soap/Server name errors

Discussion in 'Installation/Configuration' started by Nicram, Aug 6, 2013.

  1. Nicram

    Nicram Member

    Hello!
    I have spent long time trying to find solution for me.
    I'm using newest ISPConfig 3.0.5.2 on CentOS 6.4 x86_64.
    I have newest Roundcube installed (0.9.2) and newest plugin from github.
    Earlier i had older version but i updated everything.
    It looks roundcube by itself working great, without any problems.
    But the plugins i think not. If i will put inside /ispconfig3_account/config/config.inc.php line:
    $rcmail_config['soap_url'] = 'http://localhost:9090/remote/';
    or $rcmail_config['soap_url'] = 'http://my.server.dns:9090/remote/';
    Then Roundcube loads, but on the special ispconfig 3 plugins there is Soap error.
    If i change it into:
    $rcmail_config['soap_url'] = 'https://localhost:9090/remote/';
    or $rcmail_config['soap_url'] = 'https://my.server.dns:9090/remote/';
    Then it cannot login at all saying "unknown server name" at login screen after click on login button.
    Here is Apache log on the second settings (when i can't login):
    The error log is empty. I'm using webmail2 because i left squirremail, and i also use 9090 port instead of 8080.
    Please help anyone.
     
    Last edited: Aug 6, 2013
  2. Nicram

    Nicram Member

    Can anyone help?
     
  3. Horfic

    Horfic Member

  4. Nicram

    Nicram Member

    The error was: Soap Error: Error Fetching http headers.
    I have changed to https and now it works well after disabling the plugin.
    The funny things is i was sure it is disabled by default, my mistake.
    Thank You for help.
     
  5. Horfic

    Horfic Member

    well the autoselect plugin works, but it needs configuration, it doesn't work out of the box.
     

Share This Page