Roundcube Soap Error

Discussion in 'Tips/Tricks/Mods' started by skoena, Jul 10, 2013.

  1. skoena

    skoena Member

    Installed Roundcube like this:
    https://github.com/w2c/ispconfig3_roundcube/wiki/Installation-Instructions-(package)

    I get a lot of Soap errors
    At number 5 of the instruction
    https://github.com/w2c/ispconfig3_roundcube/wiki/Installation-Instructions-(manual)

    It sais add:
    But I guess this is not applicable for my type of installtion via (package)?
    (and I slo don't know the REMOTE PASSWORD?)
     
  2. luatbravo

    luatbravo New Member

    thank ziu so much
     
  3. skoena

    skoena Member

    Any tips, suggestions?
     
  4. Croydon

    Croydon HowtoForge Supporter

    Maybe you have to change http to https in the config?
     
  5. Horfic

    Horfic Member

    well you should only need to switch from http to https

    in

    $rcmail_config['soap_url'].


    btw the password is in the ispconfig database in software_package row package_config
     
  6. Croydon

    Croydon HowtoForge Supporter

    I think he means the remote user password of ISPConfig.

    This is what you set when you created the remote user in ISPConfig under system -> remote users.
    You can not use your normal admin user of ISPConfig to access the remoting, if that's what you tried.
     
  7. Horfic

    Horfic Member

    i do know that he means this password and as he installed it per package system, the password gets generated and saved as cleartext in the database.

    software_package row package_config
     
  8. Croydon

    Croydon HowtoForge Supporter

    Ok, i read that over, sorry :)
     
  9. skoena

    skoena Member

    When I change into
    in config
    And try to login I get a error:
     
  10. Croydon

    Croydon HowtoForge Supporter

    Invalid server name is a message that (also?) occurs if the given user does not exist as a mail login in ISPConfig, so the roundcube plugin cannot find the corresponding server to login to.
    But it means that the change from http to https seems to be correct.
     
  11. skoena

    skoena Member

    I'm getting the initial error in my first post "Soap Error: Error Fetching http headers" when I am succesfully logged in as a user.

    When I change into

    Quote:
    $rcmail_config['soap_url'] = 'https://mine.com:8080/remote/';

    in config
    Quote:
    /var/www/apps/roundcube/plugins/ispconfig3_account/config/config.inc.php

    And try to login I get a error:
    Quote:
    "Invalid server name"

    So I'm not able to login when I change from http to https.
     
  12. Horfic

    Horfic Member

    as i stated, disable the autoselect plugin, you didn't set it up correctly, so disable it.
     
  13. skoena

    skoena Member

    Did I mis something?
    Where did you state this?

    How to disable it and where?
     
  14. skoena

    skoena Member

    No tnx Horfic I'm not paying 50 euro for you to setup a plugin that will maybe fix my issue.

    I will wait for somebody to help me on these forums.
     
  15. Horfic

    Horfic Member

    Last edited: Aug 27, 2013

Share This Page