roundcube soap error: bad request

Discussion in 'Plugins/Modules/Addons' started by Sergio Cesar, May 18, 2018.

  1. Sergio Cesar

    Sergio Cesar New Member

    Trying to change the user password via roundcube, I get this error " soap error: bad request" it it not only does not change the password, and I also get the same error when i click in any of the options under "account" tab.
    looking at the logs I find this: <<<<< did I miss configuring something?

    [18-May-2018 14:42:41 -0500]: <j4qckvon> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/)
    [18-May-2018 14:43:22 -0500]: <j4qckvon> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (POST /webmail/?_task=login?_task=login&_action=login)
    [18-May-2018 14:43:23 -0500]: <85st8l6a> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/?_task=mail)
    [18-May-2018 14:43:31 -0500]: <85st8l6a> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/?_task=settings)
    [18-May-2018 14:43:36 -0500]: <85st8l6a> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/?_task=settings&_action=plugin.ispconfig3_account)
    [18-May-2018 14:43:38 -0500]: <85st8l6a> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/?_task=settings&_action=plugin.ispconfig3_account.show&_framed=1)
    [18-May-2018 15:07:36 -0500]: <85st8l6a> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/?_task=settings&_action=plugin.ispconfig3_account)
    [18-May-2018 15:07:40 -0500]: <85st8l6a> PHP Error: Failed to load config from /var/lib/roundcube/plugins/jqueryui/config.inc.php in /usr/share/roundcube/program/lib/Roundcube/rcube_plugin.php on line 157 (GET /webmail/?_task=settings&_action=plugin.ispconfig3_account.show&_framed=1)
     
  2. Sergio Cesar

    Sergio Cesar New Member

    UPDATE:
    I added the content of /usr/share/roundcube/plugins/jqueryui/config.inc.php.dist
    to the /var/lib/roundcube/plugins/jqueryui/config.inc.php and now the above errors are gone.
    but not the display of
    soap error: bad request
    when I click on any other option of "account", no error in any log that I can think of looking at.
    any idea would is appreciated.
     
  3. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    my first thought yesterday was:
    those are different issues regarding file / path permissions.
    Do you use a self signed tls cert for your panel? If no, do you use the given / valid hostname for your soap request?

    but hmmm if other operations do work - there might be an issue with the permissions of the remote ispconfig user?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Or an issue with the IDS, try to update to ISPConfig git-stable or disable / set higher score levels for the IDS.
     
  5. Sergio Cesar

    Sergio Cesar New Member

    WOW!! thanks both for the reply but I am very new to ispconfig and have no clue what either one is talking about.
    I am using letsencrypt for both the ispconfig control panel and the domain the user email belong to.
    I have just updated ispconfig to git-stable.
    login to roundcube as the user, click on settings, and by clicking on "account" the error is still there "Soap Error: Bad Request" no errors in the roundcube log or apache2 error log
    <QUOTE>or disable / set higher score levels for the IDS.</QUOTE>
    No idea what you mean for IDS.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    IDS can not be the problem when the issue persists after updating to git-stable. Try to take a look into the global apache error.log to see which error shows up there when you get the 500 error.
     
  7. Sergio Cesar

    Sergio Cesar New Member

    absolutely no error in the /var/log/apache2/error.log
    the error is not a literal 500 error but a popup from within roundcube that just say:
    "Soap Error: Bad Request" and an X to close the popup.
     
  8. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    there was a step in the howto creating the config-file for roundcube including the soap-user/pass.
    What did you enter as soap hostname? Was is the domain name your letsencrypt certificate is valid for?
     
  9. Sergio Cesar

    Sergio Cesar New Member

    Digging into /var/lib/roundcube/plugins/ispconfig3_account/config/config.inc.php
    I find this below.
    <?php
    $rcmail_config['identity_limit'] = false;
    $rcmail_config['remote_soap_user'] = 'roundcube';
    $rcmail_config['remote_soap_pass'] = 'secret';
    $rcmail_config['soap_url'] = 'https://isp.mydomain.tdl:8080/remote/';
    ?>
    I logged into the admin panel ->> system >> remote users and re-entered the password for the user roundcube as in the file and the error is now gone.
    so, happy I logged into roundcube user email and try to change the email password for the user and now I get this one.
    "Soap Error: There is no sysuser account for this client ID."

    a sidenote: I pointed my browser to the link /remote/ and I get nothing but a blank screen. is this normal?
     
  10. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    seems domains need to be owned by some ISPConfig-customer before this script works for it, empty value is allowed for adding defaulting to admin ownership but I don't know whats inside the plugin ... anyways, connect domain with client.

    And yes, it is ok to see a white page
     
  11. Sergio Cesar

    Sergio Cesar New Member

    Resolved (sort off) I think I found why this is happening.
    Roundcube is running on the localhost so I preset /etc/roundcube/config.inc.php
    $config['default_host'] = '127.0.0.1';
    to get rid of the 3rd box at login.
    once I resolved the initial panel pasword issue I traced back all my custom changes thus entered the server.domain.tld the user has account and password changed ok. to verify failure again I entered localhost and 127.0.0.1 and both allowed me to login and do all email functions but not change password.
    Perhaps this could be rewritten so this does not happen and allow for a "forget_password" link to be added in the RC login as the old forget_password plugin did.
    Most users are used to login with a full email address so no need to use the server name 3rd box.
     

Share This Page