roundcube setup/cnnctn after thePerfectServerUbuntu16.04

Discussion in 'HOWTO-Related Questions' started by niemand-glaumy, Dec 15, 2017.

  1. niemand-glaumy

    niemand-glaumy New Member

    I worked through the night, I hope this isn't a duplicate question or something I just overlooked.

    I followed this:
    howtoforge.com/tutorial/perfect-server-ubuntu-16.04-with-apache-php-myqsl-pureftpd-bind-postfix-doveot-and-ispconfig/

    until the bitter end.

    Now I would like to know how to open the roundcube webmailer - or: How to set it up with ISPConfig. Because the tutorials available are only for Debian+onemorewhichisnotubuntu and ISPCFG 3, not 3.1.

    A step by step walk through for lazy linuxnooby beings would be granditiously appreciated. If it's in the Manual, I'll buy it! (will most likely do anyways)

    And thanks for the tutorial, it was great!

    --NMND

    EDIT!
    I found the link. Sadly, when I go to
    https ://ip:8080/mail/webmailer.php?id=1
    it forwards me to
    https ://ip:8080/webmail
    which displays:
    While https ://ip:8080/phpmyadmin/ displays a lot of gibberish:
    Code:
    "addJSON( 'list', PMA_RecentFavoriteTable::getInstance('recent')->getHtmlList() ); exit; } if ($GLOBALS['PMA_Config']->isGitRevision()) { if (isset($_REQUEST['git_revision']) && $GLOBALS['is_ajax_request'] == true) { PMA_printGitRevision(); exit; } echo '
    '; } // Handles some variables that may have been sent by the calling script $GLOBALS['db'] = ''; $GLOBALS['table'] = ''; $show_query = '1'; // Any message to display? if (! empty($message)) { echo PMA_Util::getMessage($message); unset($message); } $common_url_query = PMA_URL_getCommon(); $mysql_cur_user_and_host = ''; // when $server > 0, a server has been chosen so we can display // all MySQL-related information if ($server > 0) { include 'libraries/server_common.inc.php'; include 'libraries/StorageEngine.class.php'; // Use the verbose name of the server instead of the hostname // if a value is set $server_info = ''; if (! empty($cfg['Server']['verbose'])) { $server_info .= htmlspecialchars($cfg['Server']['verbose']); if ($GLOBALS['cfg']['ShowServerInfo']) { $server_info .= ' ('; } } if ($GLOBALS['cfg']['ShowServerInfo'] || empty($cfg['Server']['verbose'])) { $server_info .= $GLOBALS['dbi']->getHostInfo(); } if (! empty($cfg['Server']['verbose']) && $GLOBALS['cfg']['ShowServerInfo']) { $server_info .= ')'; } $mysql_cur_user_and_host = $GLOBALS['dbi']->fetchValue('SELECT USER();'); // should we add the port info here? $short_server_info = (!empty($GLOBALS['cfg']['Server']['verbose']) ? $GLOBALS['cfg']['Server']['verbose'] : $GLOBALS['cfg']['Server']['host']); } echo '
    ' . "\n"; // Anchor for favorite tables synchronization. echo PMA_RecentFavoriteTable::getInstance('favorite')->getHtmlSyncFavoriteTables(); echo '
    '; if ($server > 0 || count($cfg['Servers']) > 1 ) { if ($cfg['DBG']['demo']) { echo '
    '; echo '
    ' . __('phpMyAdmin Demo Server') . '
    
    [...]"
    H3LPZ! :'(
     
    Last edited: Dec 15, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The URL to webmail is freely configurable and you have to set it to the URÖ where your webmail application is installed under System > Interface config after you installed ISPConfig. Same for phpmyadmin URL.
     
  3. niemand-glaumy

    niemand-glaumy New Member

    Thanks for your reply, and yeap, I found that setting, too. But it did not solve my problem.

    Making this clear in the beginning: <m.y.i.p> is just a placeholder, same as <domain>, I don't want to publish it.
    [SERVERNAME] is also the same as the <domain>. It was web.<domain> before, but that did not make any sense to me, so I changed the hostname to <domain>, what obviously changed the Servername.

    phpmyadmin:
    Interface Config: PHPMyAdmin URL: [SERVERNAME]/phpmyadmin
    https://<domain>/phpmyadmin shows:
    https://<m.y.i.p>/phpmyadmin shows:
    the same.

    An error occurred during a connection to <m.y.i.p>. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG</quote>

    http://<domain>/phpmyadmin shows:
    and loads more...
    http://<m.y.i.p>/phpmyadmin shows:
    the same.

    Firefox Developer Web Console shows:
    while http://<m.y.i.p>:8080/phpmyadmin/ shows:
    webmail
    Interface Main Config > Webmail URL: webmail.[SERVERNAME]
    DNS has a dns zone for webmail.<domain>.
    And later there were no changes when I changed Interface Main Config > Webmail URL to [SERVERNAME]/webmail

    URLS and what the browser shows:
    webmail.<domain> displays the white green default ISPConfig site.
    webmail.<m.y.i.p> displays
    Each the same in https as well as http.

    https://<domain>/webmail (Same as https://<domain>:8080/webmail)
    https://web.<domain>/webmail
    https://<m.y.i.p>/webmail
    http://<domain>/webmail => www.<domain>/webmail (it gets automatically converted, in the domain settings, I put this to "no auto subdomain", why is it still changing?.
    http://<m.y.i.p>/webmail
    https://web.<domain>:8080/webmail || https://<m.y.i.p>:8080/webmail

    ping + tracert
    Also: ping web.<domain> as well as tracert web.<domain> work, but both won't work with ping/tracert <domain>.

    Hostname in ISPConfig System > Server Config is <domain>.

    If required, I will send you login and ip via PM, if you initiate contact.[/quote][/quote]
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The URL of phpmyadmin is http://serverhostname/phpmyadmin or http://serverip/phpmyadmin when the server has been installed properly. Seems as if your server has a problem with PHP, maybe you did not install or activate mof_php as described in the perfect server guide.

    and the webmail application is available under the url http://serverhostname/webmail or http://serverip/webmail or http://serverhostname/roundcube or http://serverip/roundcube depending on the alias you have sed during setup.

    The hostname of a server has to be a subdomain like web.domain.tld. Don't change it to domain.tld as parts of your server will stop working then.

    If you need help by remote login, contact the business support: http://www.ispconfig.org/get-support/?type=ispconfig
     
    niemand-glaumy and xnooztv like this.
  5. xnooztv

    xnooztv New Member

    Nice thanks you dude
     
  6. niemand-glaumy

    niemand-glaumy New Member

    Servus Till! Thank you for your reply and time. Sadly, I need more of it. (EDIT in the end of writing this post: It is solved. Please fly over the post anyways and read my last statement, for it seems to be a ISPConfig Issue. :) The Post Scriptum just requests a feature.)

    I changed the server hostname back to web.domain.tld. (No changes)

    Redoing "The Perfect Server" (as linked in the OP) Steps 8 and 8.2 (page) leads to Ubuntu stating that everything is already installed.
    Opening domain.tld/phpinfo.php via browser works, the file is displayed as usual. (anything I should look for in there to find the error?)
    Means: PHP works for the domains, at least, but not for phpmyadmin.

    Again and still:
    domain.tld/phpmyadmin, same as [server_ip]/phpmyadmin shows the pure php document like a .txt (it is better displayed in chrome than Firefox, jfyi) and does not translate it to php.

    In the comments to "The Perfect Server", page 3, a user named "gab4mad" says:
    When I follow those instructions and reload /phpmyadmin, the browser tries to download a 22kb sized file, so I deleted the line again.

    I then found your comment on page 1 of "The Perfect Server":
    When I do that
    Code:
    ls -la /etc/apache2/mods-enabled/php*
    I get
    But:
    Now, googling "no php in apache2 mods enabled" and clicking on the first answer brought me to askubuntu, where the most voted answer has a small cmd in it, that solved my issue completely:

    SOLUTION
    Code:
    sudo a2enmod php7.0
    service apache2 restart
    The result was:

    Now there is one issue to be solved:

    While the ISPConfig 3.1 > System > Interface > Main Config > Mail
    Shows: Webmail URL: [SERVERNAME]/webmail, the working url is: domain.tld/roundcube

    domain.tld/webmail still gives me a 404.

    Thank you for your support!
    --Floh

    PS: Could you please add a [PREV] and [NEXT] button to the top of the tutorial pages? It is seriously annoying to scroll down until those buttons appear, especially because they are in the middle of the page, because of the comments. Just some userfriendlyness-feedback. :)
     
    sobhsepid likes this.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The URL depends on the alias that you have set in the apache roundcube file. search for the roundcube.conf file in the apache conf folder (/etc/apache2/conf.d/ or /etc/apache2/conf-enabled) and change the alias line from /roundcube to /webmail.
     
    sobhsepid and niemand-glaumy like this.
  8. niemand-glaumy

    niemand-glaumy New Member

    perfect, thank you! <3
     
    sobhsepid likes this.

Share This Page