Roundcube problems error 500/SMTP

Discussion in 'General' started by keybd_user, Jun 22, 2021.

  1. keybd_user

    keybd_user Member

    Hi,
    I have ISPconfig 3 on a Centos 7 server installed and the other day I accessed email on Roundcube (version 1.3.9) and i had an error saying SMTP connection error.
    Roundcube can see all email but can not send any email. I did not alter Any configuration on postfix or firewall or anything else.
    This was working correctly previously.
    Inside the apache logs I can see the message:
    Code:
    [autoindex:error] [pid 29387] [client 127.0.0.1:33498] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
    After watching this and checking for some warnings about security upgrades I decided to upgrade Roundcube.
    Upgraded to version 1.3.16 ...
    Same exact results!
    I noticed also that I could Only access roundcube on mydomain.tld/webmail If I did not have installed the .htaccess file on the Roundcube base web directory!
    If I placed there the .htaccess i got a error 500 on the browser with the message (internal configuration error)
    The upgrade to 1.3.16 was made with the script available in the distribution and there were no warnings.
    After that I made the exact same thing upgrading to 1.4 several versions and theyball have the exact same result:
    - If there is a .htaccess on the root dir of roundcube ... Error 500 internal configuration error. no logs anywhere.
    - If I remove the .htaccess file from the root dir of Roundcube I can login, read all email all folders ... but when I try to send an email: I get the same error SMTP Error (-1) connection to server failed.
    On the apache logs I get:
    Code:
    [autoindex:error] [pid 29387] [client 127.0.0.1:33498] AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
    And on Roundcube I get:
    Code:
    [22-Jun-2021 21:34:32 +0200]: <t2m4a65a> PHP Error: Connection refused (POST /webmail/?_task=mail&_unlock=loading1624390471335&_framed=1&_lang=en&_action=send)
    [22-Jun-2021 21:34:32 +0200]: <t2m4a65a> PHP Error: Failed to connect socket: Connection refused (POST /webmail/?_task=mail&_unlock=loading1624390471335&_framed=1&_lang=en&_action=send)
    [22-Jun-2021 21:34:32 +0200]: <t2m4a65a> SMTP Error: Connection failed: Failed to connect socket: Connection refused in /usr/share/roundcubemail/program/lib/Roundcube/rcube.php on line 1702 (POST /webmail/?_task=mail&_unlock=loading1624390471335&_framed=1&_lang=en&_action=send)
    
    Anyone had the same problem if so what is the solution to cure this?
    Regards
     
    Last edited: Jun 22, 2021
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    What settings do you have in roundcube for smtp/sending?
     
  3. keybd_user

    keybd_user Member

    Hi,
    I'm using right now version 1.4.11 (latest from roundcube)
    From /usr/share/roundcubemail/config/defaults.inc.php
    Code:
    $config['smtp_server'] = 'localhost';
    $config['smtp_port'] = 25;
    $config['smtp_pass'] = ''; 
    $config['smtp_auth_type'] = '';
    $config['smtp_auth_cid'] = null;
    $config['smtp_auth_pw'] = null;
    $config['smtp_helo_host'] = '';
    $config['smtp_timeout'] = 0;
    $config['smtp_conn_options'] = null;
    Notice that some of the option were Not the default for this version, I changed them to the current values but the results were always the same.
    namely smtp_user was
    Code:
    $config['smtp_user'] = '%u';
    and
    Code:
    $config['smtp_pass'] = '%p';
    none of that mattered to the issue.
    Same result as before.
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Is postfix running, and listening in localhost port 25 (on the roundcube server)?
    It doesn't hurt, setting the username and password is needed if you use port 465 or 587.
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    The config is usually in /etc/roundcube/config.inc.php, unless that's different on CentOS. You are now editing a file that should not be edited.
     
  6. keybd_user

    keybd_user Member

    I have the original install of roundcube and IPSConfig (3.2.2) on Centos 7 (lattest) and the config folder is in /usr/share/roundcubemail/config/config.inc.php
    Also changing those parameter does not have any impact.
    Running the ISPConfig status report script only shows that port 465 is not listening and on postfix config port 587 is not enabled ... but I use explicitly port 25.
    Still not getting out of this strange behavior.
     

Share This Page