Roundcube problem...

Discussion in 'Installation/Configuration' started by T1mur, Jun 22, 2011.

  1. T1mur

    T1mur New Member

    Hi

    i got instaled roundcube like in
    http://www.howtoforge.com/easy-roun...th-fail2ban-for-ispconfig-3-on-debian-squeeze

    got small problem and have no idea how to resolve it...
    after http://my.domain.org/webmail/ i got

    CONFIGURATION ERROR
    main.inc.php was not found.
    Please read the INSTALL instructions!

    what can be wrong after apt-get installation ?

    regards.

    Edit:
    is that can be the problem ?

    root@ns38685:/usr/share/roundcube# ls -l

    drwxr-xr-x 2 root root 4096 Jun 22 13:12 bin
    lrwxrwxrwx 1 root root 25 Jun 22 13:12 config -> /var/lib/roundcube/config
    -rw-r--r-- 1 root root 9829 Oct 31 2009 index.php
    lrwxrwxrwx 1 root root 23 Jun 22 13:12 logs -> /var/lib/roundcube/logs
    -rw-r--r-- 1 root root 18294 Oct 18 2010 main.inc.php.dist
    lrwxrwxrwx 1 root root 26 Jun 22 13:12 plugins -> /var/lib/roundcube/plugins
    drwxr-xr-x 7 root root 4096 Jun 22 13:12 program
    -rw-r--r-- 1 root root 26 Mar 22 2008 robots.txt
    lrwxrwxrwx 1 root root 24 Jun 22 13:12 skins -> /var/lib/roundcube/skins
    lrwxrwxrwx 1 root root 23 Jun 22 13:12 temp -> /var/lib/roundcube/temp

    /usr/share/roundcube/config# ls -l

    lrwxrwxrwx 1 root root 25 Jun 22 13:12 db.inc.php -> /etc/roundcube/db.inc.php
    lrwxrwxrwx 1 root root 27 Jun 22 13:12 main.inc.php -> /etc/roundcube/main.inc.php
    lrwxrwxrwx 1 root root 28 Jun 22 13:12 mimetypes.php -> /etc/roundcube/mimetypes.php
     
    Last edited: Jun 22, 2011
  2. marco

    marco New Member

    You must have to create a database for ROUNDCube.
    Also run the installer script in the installer folder.

    regards

    Marco
     
  3. 8omas

    8omas Member HowtoForge Supporter

  4. 8omas

    8omas Member HowtoForge Supporter

    He should NOT do this. The manual is based on apt-get installation of roundcube. He should not mess things up.
    The problem and the answer is here
    http://www.howtoforge.com/forums/showthread.php?t=51742&page=3#24
     
  5. LAKSHA

    LAKSHA Member

    Hello
    I followed this tutorial and all is smooth except the roundcube
    debian 8.6 perfect server
    perfect-server-debian-jessie-nginx-bind-dovecot-ispconfig-3.1

    last part where symlin is created with roundcube and squirrel mail .when we open the webmail url i get the following error
    CONFIGURATION ERROR
    config.inc.php was not found.
    Please read the INSTALL instructions!
    url is aksha.info:8081/squirrelmail/
     
  6. LAKSHA

    LAKSHA Member

    oops the url is laksha.info:8081/webmail
     
  7. ahrasis

    ahrasis Active Member

    To locate the complained file run:
    Code:
    updatedb
    locate config.inc.php
     
    Last edited: Mar 16, 2017
  8. Clemente Nogueira

    Clemente Nogueira New Member

    Hello, I notice that roundcube drops down with that message error after I check the System - Server config.
    The ISPConfig 3.1 auto saves and the roundcube pop this error message. It's the 3th time I test it and hapens after I check the system config. So, this is about ISPConfig 3.1 System configuration, but still not found what detail is it, because hapens without I change anything.
    My idea is that somehow ISPConfig saves something that override the proper configuration and brakes the roundcube access.
     
    luigi mangili likes this.
  9. ahrasis

    ahrasis Active Member

    I think ISPC system config only enable the /webmail extension for the browsers and do nothing to roundcube.

    My roundcube is accessed via (apps port of) domain.tld:8081/webmail (previously via domain.tld:8080/webmail), so my thought is, did you enabled it via this port 8081 (or 8080) too, but later trying to access it directly via port 80 i.e. domain.tld/webmail (without 8081 or 8080)?
     
  10. Clemente Nogueira

    Clemente Nogueira New Member

    Yes, Roundcube works fine days over, I create mail boxes, I receive emails, I send emails, all works fine at port 8081. Till I access the System Config, ISPConfig auto saves and then the warning pops.

    CONFIGURATION ERROR
    config.inc.php was not found.
    Please read the INSTALL instructions!

    I check the database access config, username, password == all fine.
    I check config.inc.php == all fine.
    It is bugging me how this happens, but the ISPconfig have some influence that break the Roundcube access.

    How I'm certain? Because I installed fresh the ISPconfig, 3 times only to test the theory and always the same.
    Roundcube works fine till I access the System Config Panel.

    Port 80 is for website
    Port 8080 is for ISPConfig
    Port 8081 is for phpMyAdmin and Roundcube.
    phpMyadmin always work fine, problem is Roundcube.
     
    luigi mangili likes this.
  11. ahrasis

    ahrasis Active Member

    I don't think it is ISPC problem because, so far that I know, none of it is modifying RC.

    Mine is Ubuntu 16.04 + Nginx and RC do work no matter how many times my ISPC > Server Config > Mail is auto saving.

    What is the content of your settings there? What is your distro / build? What is the version of your RC?
     
  12. Clemente Nogueira

    Clemente Nogueira New Member

    • Ubuntu 16.04.1 LTS, 4.8.0-46-generic
    • nginx: Installed: 1.10.0-0ubuntu0.16.04.4
    • roundcube: Installed: 1.2~beta+dfsg.1-0ubuntu1
    • postfix: Installed: 3.1.0-3
    • PHP 7.0
    I'm sure the problem is in the ISPConfig interface.
    It's a matter of logic. If the problem happens only when I access to System, Server Config and after auto save the warning in Roundcube appears, then the problem also will be of that factor.

    In the Server - Config you have many configuration factors, Server, Mail, Getmail, Web, etc. ISPConfig auto save it all when you change from any tab.

    After ISPConfig (red circle update) "datalog_status_u_server:2" finish, the roundcube error window pop up.

    I can consider that the change is not directly in the Roundcube core, but it is certainly some feature that the Roundcube uses to work and has been compromised or not installed. Or else maybe the security permissions to some folder or file, let's suppose.
     
    Last edited: Apr 17, 2017
  13. ahrasis

    ahrasis Active Member

    Sorry, but I don't see anything that could have changed RC in there. Anyway, have a good luck fixing it your way then.
     
  14. Clemente Nogueira

    Clemente Nogueira New Member

    Yes, this is difficult to solve because I really do not know what ISPConfig modifies for this to happen. Maybe if a developer in ISPConfig finds out if they can solve the problem in a future version of ISPConfig. For me I'll have to waste hours debugging to figure out the solution. Or change software.
    But anyway, thank you for trying to help.
     
  15. Viktor

    Viktor New Member

    In Roundcube out of the box permission on some files & dirs depends on user is apache running as - www-data.
    In nginx the apps.vhost running as ispapps user. After ISPConfig installation the permissions do not change.
    Try to use:
    chown root:ispapps /etc/roundcube/debian-db.php
    chmod 640 /etc/roundcube/debian-db.php
    chown root:ispapps /etc/roundcube/config.inc.php
    chmod 640 /etc/roundcube/config.inc.php
    chown -R ispapps:adm /var/log/roundcube
    chmod -R 750 /var/log/roundcube
    chown -R ispapps:ispapps /var/lib/roundcube/temp
    chmod -R 750 /var/lib/roundcube/temp
     
    ahrasis likes this.
  16. Clemente Nogueira

    Clemente Nogueira New Member

    Than you Viktor I tested it today in a Debian 8.8.0 server and worked very well after the error appeared.
     
  17. For my work
    change
    chmod 640 /etc/roundcube/config.inc.php
    to
    chmod 644 /etc/roundcube/config.inc.php
     
  18. Lucas Nascimento

    Lucas Nascimento New Member

    I've got the same problem, when I access System Config something happened that changed RC somehow.
    To fixed that I've run the command below.
    ispconfig_update.sh
    This update the system and make some corrections if anything went wrong.
    Hope it helps.
     

Share This Page