roundcube problem www.mysite.com/webmail

Discussion in 'Installation/Configuration' started by fordwrench, Jul 23, 2011.

  1. fordwrench

    fordwrench Member HowtoForge Supporter

    I installed ispconfig on debian 6 with this guide.

    http://www.howtoforge.com/perfect-server-debian-squeeze-with-bind-and-courier-ispconfig-3

    Then followed with this guide.

    http://www.howtoforge.com/extending-perfect-server-debian-squeeze-ispconfig-3

    when I enter www.mysite.com/webmail

    it gives this error

    Iceweasel can't establish a connection to the server at www.mysite.com:8080

    I can get to roundcube with:
    https://www.mysite.com:50443/webmail

    How to I fix it so that when I put in www.mysite.com/webmail it redirects to

    https://www.mysite.com:50443/webmail


    Fordwrench
     
  2. fordwrench

    fordwrench Member HowtoForge Supporter

    Anyone?... 72 views and not a hint....

    Have have read every post having to do with webmail and roundcube and have not found the answer.
     
  3. fordwrench

    fordwrench Member HowtoForge Supporter

    Nevermind :D

    I got fixed... one guide had me create file roundcube in
    /etc/apache2/conf.d/

    and there was also roundcube.conf file in the same dir with conflicting config information.


    Thanks for looking ...hope this helps someone else.
     
  4. fordwrench

    fordwrench Member HowtoForge Supporter

    Well I thought I had it fixed completely, but no....

    Some sites work with www.mysite.com/webmail

    some download = download.php


    <?php

    /**
    * index.php
    *
    * Redirects to the login page.
    *
    * @copyright 1999-2010 The SquirrelMail Project Team
    * @license http://opensource.org/licenses/gpl-license.php GNU Public License
    * @version $Id: index.php 13893 2010-01-25 02:47:41Z pdontthink $
    * @package squirrelmail
    */

    // Are we configured yet?
    if( ! file_exists ( 'config/config.php' ) ) {
    echo '<html><body><p><strong>ERROR:</strong> Config file ' .
    '&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
    'configure SquirrelMail before you can use it.</p></body></html>';
    exit;
    }

    // If we are, go ahead to the login page.
    header('Location: src/login.php');

    ?>


    Originally I had squirrelmail
    Now I have roundcube mail
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Do all your sites have PHP enabled? Do they all use the same PHP mode?
     
  6. erosbk

    erosbk New Member

    sed -i '1 i AddHandler application\/x-httpd-php .php .php3 .php4 .php5' /usr/share/roundcube/.htaccess

    This should fix your problem with any php mode selected in every site. It is working for me, but use it at your own risk :p

    (basically, every time a client access roundcube, this line will change the handler used by roundcube)
     
  7. 8omas

    8omas Member HowtoForge Supporter

    As I mention in http://www.howtoforge.com/extending-perfect-server-debian-squeeze-ispconfig-3-p2 you have to paste some line in the end of the file, so as the redirection to port 50443 is made.

    Did you do this?
     
  8. 8omas

    8omas Member HowtoForge Supporter

    Have in mind that the tutorial assumes the redirection of all ssl traffic to ISPCONFIG to port 50443. So if you want ssl for roundcube you have to paste the two directives.
    If you don't want to change ports then you must skip the parts of redirecting to port 50443.
    It all or nothing thing..
    Either you change the port 8080 to 50443 for all ssl traffic or not.
     

Share This Page