Roundcube problem - relay acces denied

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Mar 4, 2017.

  1. muekno

    muekno Member HowtoForge Supporter

    my mailserver in an ISPConfig multiserver enviorement works fine sind months, for me and customers. Today I realized I get relay access denied when I send via roudcube. Do not know since when as roundcube is not used very often, most customers use Outlook or thunderbird via IMAP and SMTP, but could not be long, some days only. The mailserver also works as relay for my local mailserver here.
    So first I tried to send mail from my local mail account to the same recipient as from Roudcube - works fine
    The I took Thunderbird loged in with the same account as from roudcube sent a message to the same recipient - fine
    Loged in again at roudcube same problem.
    So simple Email relaying is OK as I can see in the logs and checking login in to my external test account
    Dovecot should be OK too as sending and receiving works fine for different users and different recipients, as I can see in the logs and checking login in to my external test account
    Receiveing mail that means reading received test mail is OK too
    But sending from Roundcube gives me relay access denied for different users and different receivers at different domains
    As I knew Roudcube goes uses dovecot mail boxes for incomming mail and I think for outgoing too or am I wrong? Did no major changes since weeks, beside get latest batches when they are available.

    Has anybody any idea, will be apreciated.

    Thanks
    Rainer
     
  2. muekno

    muekno Member HowtoForge Supporter

    Problem still exists, any idea outside there?

    Rainer
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Is RoundCube installed on the mail server or the web server?
     
  4. muekno

    muekno Member HowtoForge Supporter

    On the mailserver, so it is local to postfix. Mailserver has only one IP address + 127.0.0.0 (localhost)
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the config files of roundcube and ensure that you use localhost for all server settings (smtp and imap) there. Then check postfix main.cf file and ensure that you the IP 127.0.0.1 listed in mynetworks and finally check /etc/hosts and ensure that IP 127.0.0.1 is listed there for localhost and localhost.localdomain.
     
  6. muekno

    muekno Member HowtoForge Supporter

    Solved
    all the entries you mentioned are ok. The reason was that shit IPv6. Roundcube connects postfix with IPv6 localhost[::1], inet_protolcols in postfix was set to all. But no IPV6 listet in mynetworks. After setting inet_protocols ipv4, roundcube still connects via ipv6 but postfix relay the message no with ipv4.
    I see more and more that things defaults to IPv6, what makeing problems and you have to explicit set setting to IPv4.

    Thanks for help

    Rainer
     
  7. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    have similar if not the same problem, but I have rouncube installed on the web server so setting the inet_protocols ipv4 in main.cf didnt help. I think openssl is cauisng my problem becouse I started getting this problems after I updated is.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the main.cf file on the mail server and ensure that the IP address(es) of the web server are listed in the mynetworks line.
     
  9. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    added it mynetworks = 127.0.0.0/8 [::1]/128 192.168.123.172
    but still not working. I think the problem is openssl as I said in my thread. Because ISPConfig does not work on firefox.
     
  10. muekno

    muekno Member HowtoForge Supporter

    I found the problem by exactly analyzing the postfixlog file, perhaps you post the relevant parts here. Tip open a SSH connection an to a tail -f to the postfix mail.log, while send mail via RoudCube in the other window
     
  11. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    Thanks for trying to help but it was a different problem.
    Had to add
    SSLUseStapling on
    SSLStaplingCache shmcb:/tmp/stapling_cache(128000)
    into ispconfig.conf in sites-availible like Till suggested in my forum topic.
     

Share This Page