roundcube postfix tls error

Discussion in 'Server Operation' started by Huib, Jan 24, 2020.

  1. Huib

    Huib New Member

    I set up a mail server on Ubuntu 18 with Roundcube, Dovecot and Postfix. I can login to Roundcube and receive e-mails just fine,
    but when I try to send an e-mail I get the following error in my syslog:
    postfix main:

    postfix master:

    Can anyone help me with this?

    Thank you in advance

    Attached Files:

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you cut and paste that error message to Internet Search Engines, do the articles offer useful advice?
  3. Huib

    Huib New Member

    Thank you for your reply. Yes, I tried several possible solutions, like excluding certain ssl-protocols, uncommenting lines in the postfix main config file (as instructed in the perfect server guide) and more, but none of them seemed to have worked. So my next step was to post my configuration here and see if anyone can spot what I'm doing wrong.
  4. Huib

    Huib New Member

    I fixed it. I had my domain as the hostname and smtp server in the roundcube config file. But since roundcube and postfix are on the same server, they both should have been localhost. I also read here:
    that, since theyre on the same server, tls is not necessary for roundcube since the e-mails don't go over an external network.

    Does this mean that configuring postfix to use TLS is enough to secure my outgoing e-mails?
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  6. Huib

    Huib New Member

    My apologies, I should have prepared a little more before opening this thread. I am not running ISPConfig, just Roundcube, Dovecot, MariaDB and Postfix. The error came from Postfix, suggesting that the client (Roundcube, I presume) was trying to open a connection using ssl3. Like I mentioned in my last post, I changed the hostname and smpt server in my roundcube configuration to localhost, bypassing tls (since roundcube and postfix are on the same server). It works now, I am able to send and receive e-mails. I was just wondering if bypassing TLS between roundcube and postfix could cause any proplems or security breaches, or if it doesn't matter because they are on the same server?

    Thanks in advance
  7. Steini86

    Steini86 Active Member

    Doesn't matter when they are on the same server.
    You will get problems, if(!) you enforce TLS encryption in the future for your clients. But as long s it works, its fine.
    Huib likes this.

Share This Page