RoundCube plugins : Soap Error: There is no sysuser account for this client ID.

Discussion in 'Plugins/Modules/Addons' started by pejot, Aug 30, 2013.

  1. pejot

    pejot New Member


    I have setup a mail and www server with ISPConfig

    All working great but i have problem witch RoundCube plugin ispconfig3

    When I want change pass, autoreplay, forward and clicking save im geting error

    Of course i added remote user.

    I have one client in system one domain.

    How can i repair that?

    OK. I this problem shows when i create mail account looks like [email protected] and give optional login. When i create account without login all works great.

    Help me with this i can't delete all logins becouse users working now on email client and logins witch that login.
    Last edited: Aug 30, 2013
  2. Horfic

    Horfic Member

    well what ispconfig version and which plugin version are you using.
  3. pejot

    pejot New Member

    Plugin downloaded today from svn.
    ISPConfig 3.0.5
  4. Horfic

    Horfic Member

  5. pejot

    pejot New Member

    Installed plugin from github but same error. What can i do in that case?

    In table client i have client_id "1" and in sys_user i have row witch client_id witch "1".

    All looks good.

    Help me plz.
    Last edited: Sep 3, 2013
  6. pejot

    pejot New Member

    I "repair" my problem.

    I'm using only one plugin for change pass ...

    My steps:

    in line 67 and 155 change

    login to email

    $mail_user = $this->soap->mail_user_get($session_id, array('[B]email[/B]' => $this->rcmail_inst->user->data['username']));
    and in

    in line 102 change

    login to email

    $mail_user = $this->soap->mail_user_get($session_id, array('[B]email[/B]' => $this->rcmail_inst->user->data['username']));
    In other plugins i think it will be the same "trick".
  7. Horfic

    Horfic Member

    this was the old method to get the corresponding mail account.

    with newer version the mail server behind ispconfig verifies against the login, which is in my case the same.

    so in the ispconfig db table mail_user
    i have got a field email and a field login which are the same for me as I'm not allowing custom login names.

    how are your email and logins build, what format?

    email => [email protected]
    login => test

  8. pejot

    pejot New Member

  9. Horfic

    Horfic Member


    email = [email protected]
    login = first.last

    is roundcube login adding automatically the domain to it? so that you login with first.last the real login is then [email protected]

    because the


    gives only the username which you logged in. e.g

    email = [email protected]
    login = hello

    roundcube doesn't add the domain to it.

    so the username is hello

    if roundcube adds domain it would be [email protected] which would be wrong


    as you can see in the examples, it is the login field to get the information, as the the email and the login can be something completly different. so your attempt may solve your issue, but probably only for few mail accounts, you should probably check your mail_user table and your mail server settings

Share This Page