RoundCube on multisite server

Discussion in 'Installation/Configuration' started by TheRob, Mar 22, 2020.

  1. TheRob

    TheRob New Member


    I have an issue on my brand new Debian10 I installed few days ago.
    Now several website are installed and works properly.
    I am working on mails and I am facing an issue :
    On some fqdn, I can reach the /webmail, and on some other, not ...
    Here is the error message from Apache :
    [Sun Mar 22 17:55:46.734850 2020] [php7:warn] [pid 9485] [client] PHP Warning: require_once(): open_basedir restriction in effect. File(/usr/share/roundcube/program/include/iniset.php) is not within the allowed path(s): (/var/www/clients/client14/web42/web:/var/www/clients/client14/web42/private:/var/www/clients/client14/web42/tmp:/var/www/****/web:/srv/www/****/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom) in /usr/share/roundcube/index.php on line 40
    [Sun Mar 22 17:55:46.734895 2020] [php7:warn] [pid 9485] [client] PHP Warning: require_once(/usr/share/roundcube/program/include/iniset.php): failed to open stream: Operation not permitted in /usr/share/roundcube/index.php on line 40
    [Sun Mar 22 17:55:46.734907 2020] [php7:error] [pid 9485] [client] PHP Fatal error: require_once(): Failed opening required 'program/include/iniset.php' (include_path='.:/usr/share/php') in /usr/share/roundcube/index.php on line 40

    But, I confirm that roundcube works fine on other URL I installed on my server.

    Do you have any clue, please ?
    Last edited: Mar 22, 2020
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is this an ISPConfig system despite you posting on Linux forum?
    If yes, start with this:
    I assume you have installed only one Roundcube on your system? Then it should not matter what URL you use to access it, it is the same webmail every time. I use company name as url/webmail for all e-mail users, so it is same URL for all domains and so e-mail certificate is set up easier.
  3. TheRob

    TheRob New Member

    Actually, I don't know if it whether because it is on GNU/Linux or a ISPconfig issue.
    Yes, I applied the howto instruction and yes only one roundcube installed.
    And I host multiple associations/people/companies not related. And so that's why I'd like them to go on <their_website>/webmail
    It's clearer for them.

    What I do not understand is : why is it working fine on some URL and not on others ....

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.15p3

    ##### VERSION CHECK #####
    [INFO] php (cli) version is 7.3.14-1~deb10u1
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    And that's the reason for the problem because you basically run RoundCube under their website, which mean that their website specific config interferes with RoundCube. It is better to access RoundCube through the server hostname only or a dedicated website for accessing roundcube like https://webmail.yourhostingcompany.tld
  5. TheRob

    TheRob New Member

    All right, fair enough.
    That does not answer my question, but it is a workaround.

    Thanks for your answers Taleman and Till. Your reactivity is really appreciated, thank you again.
  6. Steini86

    Steini86 Active Member

    Well, the answer is clearly written in the error message: The roundcube folder is not set in "open_basedir". Since every website has its own open_basedir settings, some of them work, some not. Add "/usr/share/roundcube" to the open_basedir and it should work.

    IMHO, the right solution is to use a specific web for webmail. Using a global alias "/webmail" on each web is a workaround.

Share This Page