Roundcube On debian 10 error 403

Discussion in 'Server Operation' started by ewkilian, Oct 29, 2020.

  1. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Depends on how you installed the extra php versions. I do not know if it is the cause of your problems. But what I would do in your situation is to set the system up as standard ISPConfig on Debian 10, and not mess it with extra installations or version changes.
    You can try
    Code:
    update-alternatives --config php
    update-alternatives --config php-cgi
    to get system default PHP back to 7.3, then Roundcube uses that. If this is not possible you would have to do a setup where roundcube is installed in a website and then that website is set up to use the PHP version you want, using ISPConfig additional PHP version mechanism.
     
  2. ewkilian

    ewkilian Member

    I create a manual file "site.com" and then a2ensite site.com. Now I see the RoundCube.
    But when I want connect to a mailbox. I have the problem :
    error connection to storage server failed
    :mad::confused:
    GRRRR :(
    thank you for your time helping me
     
  3. nhybgtvfr

    nhybgtvfr Active Member

    perhaps whatever you did before to update it, as 'su' rather than as 'su -' has messed something up somewhere, maybe it's worth going back over those commands, repeating them as 'su -' and see if that repairs any broken/missing config.
    alternatively, perhaps install everything onto a new clean vm, replicating this problem vm, and then compare them for missing packages, and config file differences.
     
  4. ewkilian

    ewkilian Member

    Its possible that I must rebuild the Roundcube DataBase ? (Because I have Upgrade MariaDB) ?
    I have try to Update ISPCONFIG with "su -" but its the same issu
     
  5. ewkilian

    ewkilian Member

    I have try :
    [email protected]:/var/www# dpkg-reconfigure roundcube-mysql
    [email protected]:/var/www# dpkg-reconfigure roundcube
    [email protected]:/var/www# dpkg-reconfigure roundcube-core
    This instance of Roundcube is up-to-date.
    Have fun!
    apache2_invoke roundcube.conf: already enabled

    it does not change anything
     
  6. nhybgtvfr

    nhybgtvfr Active Member

    yes, but your 1st post states you updated the os and packages. perhaps that is where the problem is coming from,
    maybe whatever was updated then (using just 'su'?) is causing the problem and needs re-installing/repairing.

    after all, if you have postfix installed on this machine, it should definitely also already have postmap and postalias, so there's something fundamentally more wrong with your system than just some misconfigured roundcube configs.
     
  7. ewkilian

    ewkilian Member

    I have Try with
    "su -" and then apt-get update ans apt-get upgrade. and always the same problem.
    Dovecot is Up :
    Code:
     dovecot.service - Dovecot IMAP/POP3 email server
       Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
       Active: active (running) since Mon 2020-11-02 14:26:16 CET; 2min 51s ago
         Docs: man:dovecot(1)
               http://wiki2.dovecot.org/
     Main PID: 20284 (dovecot)
        Tasks: 22 (limit: 4915)
       Memory: 19.2M
     
  8. ewkilian

    ewkilian Member

    Now in the log I see that :
    Code:
    [02-Nov-2020 14:50:14 +0100]: <erokeg40> IMAP Error: Login failed for [email protected] from 123.456.789.1. Could not connect to localhost:143: Connection refused in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 200 (POST /webmail/?_task=login&_action=login)
     
  9. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Was the IP-address you replaced with
    your IP-address? If yes, seems something is wrong with user and passwords settings in roundcube or e-mail.
     
  10. ewkilian

    ewkilian Member

    no sorry 123.456.789.1 is a fake IP.
    No I'm very sure for the login and password :(.
    I reTry ! but... nothing... Don't Connect
     

Share This Page