Roundcube : ''Message have been sent'' , but nothing happens

Discussion in 'Installation/Configuration' started by Akhilleus, Apr 30, 2019.

  1. Akhilleus

    Akhilleus Member

    Looks like I have it there too ... Should I delete the one on master.cf ? Those are the logs on main.cf

    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # See http://www.postfix.org/COMPATIBILITY_README.html -- default to 2 on
    # fresh installs.
    compatibility_level = 2
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
    myhostname = akhilleus2.akhilleus2.com
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = $myhostname, akhilleus2.akhilleus2.com, localhost.akhilleus2.com, todaysharenews.com , localhost
    relayhost =
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = hash:/var/lib/mailman/data/virtual-mailman, proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = mysql:/etc/postfix/mysql-virtual_uids.cf
    virtual_gid_maps = mysql:/etc/postfix/mysql-virtual_gids.cf
    sender_bcc_maps = proxy:mysql:/etc/postfix/mysql-virtual_outgoing_bcc.cf
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_restriction_classes = greylisting
    greylisting = check_policy_service inet:127.0.0.1:10023
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_rbl_client zen.spamhaus.org, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, check_recipient_access mysql:/etc/postfix/mysql-virtual_policy_greylist.cf
    smtpd_tls_security_level = may
    transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql-virtual_sender_login_maps.cf
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $sender_bcc_maps $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $smtpd_sender_login_maps
    smtpd_helo_required = yes
    smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, check_helo_access regexp:/etc/postfix/helo_access, reject_invalid_hostname, reject_non_fqdn_hostname, reject_invalid_helo_hostname, reject_unknown_helo_hostname, check_helo_access regexp:/etc/postfix/blacklist_helo
    smtpd_sender_restrictions = check_sender_access regexp:/etc/postfix/tag_as_originating.re , permit_mynetworks, permit_sasl_authenticated, check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf, check_sender_access regexp:/etc/postfix/tag_as_foreign.re
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    smtp_tls_security_level = may
    smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3
    smtpd_tls_protocols = !SSLv2,!SSLv3
    smtp_tls_protocols = !SSLv2,!SSLv3
    smtpd_tls_exclude_ciphers = RC4, aNULL
    smtp_tls_exclude_ciphers = RC4, aNULL
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    message_size_limit = 0
    content_filter =smtp-amavis:[127.0.0.1]:10024
    
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, it should be only in main.cf, not master.cf and as @nhybgtvfr mentioned, there are other things missing in master.cf, at least when you run a recent ISPConfig version. You should consider running an ispconfig update and choose to reconfigure services during update if you want to let the ISPConfig updater fix your config, but only do this when you have a recent operating system, doing this on an old os like Ubuntu 14.04 or CentOS 6 might cause issues.
     
  3. Akhilleus

    Akhilleus Member

    I'm running on ubuntu 18.04
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you should do an ISPconfig update ith ispconfig_update.sh command choose 'git-stable' as update source.
     
  5. Akhilleus

    Akhilleus Member

    I'm reading your tutorials , can I abort it ? . I have chosen ''Stable''

    Loading SQL patch file: /tmp/update_stable.sh.GmN5fB4soQ/ispconfig3_install/install/sql/incremental/upd_dev_collection.sql
    Reconfigure Permissions in master database? (yes,no) [no]: yes

    Service 'mail_server' has not been detected (strongly recommended, currently enabled) do you want to disable it? (yes,no) [yes]:
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    stable is ok as well. But I wonder why it shows that you don't have a mailserver.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Did this setup ever work before and if not, which tutorial did you use to set it up.
     
  8. Akhilleus

    Akhilleus Member

    I didn't . The server provider installs it by default on the plan I payed for .
    I will proceed with the installation and update with reports
     
  9. Akhilleus

    Akhilleus Member

    Ok , this is looking so bad , maybe it's needed a fresh install :(
    Everything is not detected :(

    Code:
    Service 'mail_server' has not been detected (strongly recommended, currently enabled) do you want to disable it?  (yes,no) [yes]: no
    
    Service 'dns_server' has not been detected (strongly recommended, currently enabled) do you want to disable it?  (yes,no) [yes]: no
    
    Service 'web_server' has not been detected (strongly recommended, currently enabled) do you want to disable it?  (yes,no) [yes]: no
    
    WARNING: If ISPConfig-Interface (Webfrontend) is installed on this Server we will configure the Web Server anyways but will not enable it in ISPConfig.
    
    Service 'xmpp_server' has not been detected (strongly recommended, currently enabled) do you want to disable it?  (yes,no) [yes]: no
    
    Service 'firewall_server' has been detected (currently disabled) do you want to enable and configure it?  (yes,no) [no]: no
    
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You run the update as root user, right? If yes and nothing is detected, then I don't know what kind of setup your provider offers when he claims that it's an ISPConfig setup. In that case, I would reinstall the server by using an empty (minimal) base system with e.g. Ubuntu 18.04 or Debian 9 and then follow either one of our perfect server installation guides or try using the autoinstaller.

    https://www.howtoforge.com/tutorial/ubuntu-ispconfig-automated-install-script/
    or
    https://www.howtoforge.com/tutorial/ispconfig-automated-install-script/
     
  11. Akhilleus

    Akhilleus Member

    Ok , I have proceeded anyway , installation ended . When to roundcube , tried to send a message to myself , and we're back to the start . Message have been send but nothing happens :(
     
  12. Akhilleus

    Akhilleus Member

    Ok , I'm back here after reloading ( formating ) the server with a fresh copy . Following the guide ''The Perfect Server - Ubuntu 18.04 (Bionic Beaver) with Apache, PHP, MySQL, PureFTPD, BIND, Postfix, Dovecot and ISPConfig 3.1 - Page 3''
    Everything working fine , even reinstalled my site and works fine . Back again to roundcube , error :
    Sending message... ( for an eternity , than ) Request Time Out ....
    I have to tell you , that I did not configured any DNS , I was sending the mail to myself ( from [email protected] to [email protected] )
    My actual DNS provider are Cloudflare , setting up the DNS on ISP config come from the 2 DNS provided from Cloudflare .
    Is my error coming from a DNS problem ?

    Logs ? ( Now i feed familiar with this ) xD

    #
    # Postfix master process configuration file. For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master" or
    # on-line: http://www.postfix.org/master.5.html).
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (no) (never) (100)
    # ==========================================================================
    smtp inet n - y - - smtpd
    #smtp inet n - y - 1 postscreen
    #smtpd pass - - y - - smtpd
    #dnsblog unix - - y - 0 dnsblog
    #tlsproxy unix - - y - 0 tlsproxy
    #submission inet n - y - - smtpd
    -o syslog_name=postfix/submission
    -o smtpd_tls_security_level=encrypt
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o smtpd_tls_auth_only=yes
    # -o smtpd_reject_unlisted_recipient=no
    # -o smtpd_client_restrictions=$mua_client_restrictions
    # -o smtpd_helo_restrictions=$mua_helo_restrictions
    # -o smtpd_sender_restrictions=$mua_sender_restrictions
    # -o smtpd_recipient_restrictions=
    # -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #smtps inet n - y - - smtpd
    -o syslog_name=postfix/smtps
    -o smtpd_tls_wrappermode=yes
    -o smtpd_sasl_auth_enable=yes
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o smtpd_reject_unlisted_recipient=no
    # -o smtpd_client_restrictions=$mua_client_restrictions
    # -o smtpd_helo_restrictions=$mua_helo_restrictions
    # -o smtpd_sender_restrictions=$mua_sender_restrictions
    # -o smtpd_recipient_restrictions=
    # -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - y - - qmqpd
    pickup unix n - y 60 1 pickup
    cleanup unix n - y - 0 cleanup
    qmgr unix n - n 300 1 qmgr
    #qmgr unix n - n 300 1 oqmgr
    tlsmgr unix - - y 1000? 1 tlsmgr
    rewrite unix - - y - - trivial-rewrite
    bounce unix - - y - 0 bounce
    defer unix - - y - 0 bounce
    trace unix - - y - 0 bounce
    verify unix - - y - 1 verify
    flush unix n - y 1000? 0 flush
    proxymap unix - - n - - proxymap
    proxywrite unix - - n - 1 proxymap
    smtp unix - - y - - smtp
    relay unix - - y - - smtp
    -o syslog_name=postfix/$service_name
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - y - - showq
    error unix - - y - - error
    retry unix - - y - - error
    discard unix - - y - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - y - - lmtp
    anvil unix - - y - 1 anvil
    scache unix - - y - 1 scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
    #
    # ====================================================================
    #
    # Recent Cyrus versions can use the existing "lmtp" master.cf entry.
    #
    # Specify in cyrus.conf:
    # lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
    #
    # Specify in main.cf one or more of the following:
    # mailbox_transport = lmtp:inet:localhost
    # virtual_transport = lmtp:inet:localhost
    #
    # ====================================================================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus unix - n n - - pipe
    # user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ====================================================================
    # Old example of delivery via Cyrus.
    #
    #old-cyrus unix - n n - - pipe
    # flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    #
    # ====================================================================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix - n n - 2 pipe
    flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}

    dovecot unix - n n - - pipe
    flags=DRhu user=vmail:vmail argv=/usr/lib/dovecot/deliver -f ${sender} -d ${user}@${nexthop}

    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o smtp_bind_address=


    127.0.0.1:10025 inet n - n - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtp_send_xforward_command=yes
    -o disable_dns_lookups=yes


    127.0.0.1:10027 inet n - n - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtp_send_xforward_command=yes
    -o milter_default_action=accept
    -o milter_macro_daemon_name=ORIGINATING
    -o disable_dns_lookups=yes
     
  13. Akhilleus

    Akhilleus Member

    Mail Logs from /var/log/mail.log
    May 3 01:44:34 unit-might dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=3380, secured, session=<ucZkFfaHZKMAAAAAAAAAAAAAAAAAAAAB>
    May 3 01:44:34 unit-might dovecot: imap([email protected]): Logged out in=44 out=592
    May 3 01:45:03 unit-might postfix/smtps/smtpd[3414]: connect from localhost[::1]
    May 3 01:47:02 unit-might postfix/smtpd[3271]: timeout after END-OF-MESSAGE from localhost[127.0.0.1]
    May 3 01:47:02 unit-might postfix/smtpd[3271]: disconnect from localhost[127.0.0.1] ehlo=1 mail=1 rcpt=1 data=1 commands=4
    May 3 01:48:01 unit-might postfix/smtps/smtpd[3338]: SSL_accept error from localhost[::1]: Connection timed out
    May 3 01:48:01 unit-might postfix/smtps/smtpd[3338]: lost connection after CONNECT from localhost[::1]
    May 3 01:48:01 unit-might postfix/smtps/smtpd[3338]: disconnect from localhost[::1] commands=0/0
    May 3 01:48:46 unit-might postfix/smtps/smtpd[3343]: SSL_accept error from localhost[::1]: Connection timed out
    May 3 01:48:46 unit-might postfix/smtps/smtpd[3343]: lost connection after CONNECT from localhost[::1]
    May 3 01:48:46 unit-might postfix/smtps/smtpd[3343]: disconnect from localhost[::1] commands=0/0
    May 3 01:48:51 unit-might postfix/smtps/smtpd[3338]: connect from localhost[::1]
    May 3 01:50:03 unit-might postfix/smtps/smtpd[3414]: SSL_accept error from localhost[::1]: Connection timed out
    May 3 01:50:03 unit-might postfix/smtps/smtpd[3414]: lost connection after CONNECT from localhost[::1]
    May 3 01:50:03 unit-might postfix/smtps/smtpd[3414]: disconnect from localhost[::1] commands=0/0
    May 3 01:50:27 unit-might postfix/smtps/smtpd[3414]: connect from localhost[::1]
    May 3 01:52:43 unit-might dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=3763, secured, session=<df2SMvaHcKMAAAAAAAAAAAAAAAAAAAAB>
    May 3 01:52:43 unit-might dovecot: imap([email protected]): Logged out in=70 out=633
    May 3 01:52:45 unit-might dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=3765, secured, session=<K8ypMvaHcqMAAAAAAAAAAAAAAAAAAAAB>
    May 3 01:52:45 unit-might dovecot: imap([email protected]): Logged out in=316 out=1534
    May 3 01:52:45 unit-might dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=3767, secured, session=<k2OqMvaHdKMAAAAAAAAAAAAAAAAAAAAB>
    May 3 01:52:45 unit-might dovecot: imap([email protected]): Logged out in=120 out=774
    May 3 01:52:51 unit-might dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=3769, secured, session=<GKMLM/aHdqMAAAAAAAAAAAAAAAAAAAAB>
    May 3 01:52:52 unit-might dovecot: imap([email protected]): Logged out in=32 out=485
    May 3 01:52:52 unit-might dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=::1, lip=::1, mpid=3775, secured, session=<G40XM/aHeKMAAAAAAAAAAAAAAAAAAAAB>
    May 3 01:52:52 unit-might dovecot: imap([email protected]): Logged out in=44 out=592
    May 3 01:53:12 unit-might postfix/smtps/smtpd[3796]: connect from localhost[::1]
    May 3 01:53:51 unit-might postfix/smtps/smtpd[3338]: SSL_accept error from localhost[::1]: Connection timed out
    May 3 01:53:51 unit-might postfix/smtps/smtpd[3338]: lost connection after CONNECT from localhost[::1]
    May 3 01:53:51 unit-might postfix/smtps/smtpd[3338]: disconnect from localhost[::1] commands=0/0
    May 3 01:55:27 unit-might postfix/smtps/smtpd[3414]: SSL_accept error from localhost[::1]: Connection timed out
    May 3 01:55:27 unit-might postfix/smtps/smtpd[3414]: lost connection after CONNECT from localhost[::1]
    May 3 01:55:27 unit-might postfix/smtps/smtpd[3414]: disconnect from localhost[::1] commands=0/0
    May 3 01:58:12 unit-might postfix/smtps/smtpd[3796]: SSL_accept error from localhost[::1]: Connection timed out
    May 3 01:58:12 unit-might postfix/smtps/smtpd[3796]: lost connection after CONNECT from localhost[::1]
    May 3 01:58:12 unit-might postfix/smtps/smtpd[3796]: disconnect from localhost[::1] commands=0/0
     
  14. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What shows next commands:
    Code:
    hostname
    hostname -f
    Check the settings for postfix and roundcube are exactly what the Perfect Server Guide you followed shows.
     
  15. Akhilleus

    Akhilleus Member

    [email protected]:~# hostname
    unit-might
    [email protected]:~# hostname -f
    unit-might
    [email protected]:~#
     
  16. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  17. Akhilleus

    Akhilleus Member

  18. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Fix that hostname and restart the computer. That may get it working. If not, debug further.
     
  19. nhybgtvfr

    nhybgtvfr Active Member

    as Taleman stated, you'll need to configure /etc/hostname and /etc/hosts as shown in the tutorial he linked to (step 8), and which is referred to in the 1st paragraph of step 1 in the tutorial you used. don't worry about the netplan config, that should be ok.
    hopefully that'll be enough to fix everything, but the fact that the ispconfig update didn't find the installed elements makes me suspect it won't.
     
  20. Akhilleus

    Akhilleus Member

    Ok , this is very strange . I have set up an email confirmation for registration ( I did not correct for the moment my error ) , the thing is that the email confirmation is being sent , and received . But when I try to send manually ( not automatic response mail ) , I got the eternal ''Sending message...''
    Is this normal ? ( the email confirmation were tested on gmail and hotmail . The bad news is that they were received on spam box )
     

Share This Page