RoundCube Max upload file size, ispconfig3, php7

Discussion in 'Tips/Tricks/Mods' started by Gino Carpanetti D., Sep 23, 2016.

  1. Gino Carpanetti D.

    Gino Carpanetti D. New Member

    Hello everyone.
    This is my first post so i apologise if i am posting in the wrong place or if i break some protocol.
    Also english is not my native language so sorry about that too.
    I don't know if this is already posted but i hope it helps someone because it took me a while to find it out.
    I followed the "the perfect server" tutorial for Ubuntu 16.04 inside an Azure VM. After a couple days someone asked me to increase the upload file size.
    I inmediately went to the apache2 folder and modified the php.ini file but i didn't work, didn't work also for the php.ini inside the cli, fpm and other folders.
    Anyway, i tried several things and, in the end, i made an experiment (Since i don't have advanced skils in programming).
    In many places said that you should increase the upload_max_filesize parameter inside the .htaccess file in /etc/roundcube. I did it but it doesn't work.
    Then i noticed that the module inside the file says:
    <IfModule mod_php5.c>
    But i had installed php7.0 from the tutorial.
    I tried changing it to
    <IfModule mod_php7.0.c>
    didn't work either...
    finally i tried
    <IfModule mod_php7.c> and everithing worked perfect, now i can atach files up to 50MB
    i hope it helps someone, bye.
    PD: I tried with no success to install aditional php versions following tutorial:
    But i had touble with the repositories or something related to the 16.04 version, when i have more time i will try ir again and maby post if something interesting comes out.
    hsluis likes this.
  2. CreeWarrior

    CreeWarrior Member

    I think that those changes are meant to be done in the ispconfig control panel. SITE> then chose the domain you what to change then select the option tab there you can enter custom php setting as well as apache directives. I was wondering if it was the email file attachment size they were talking about or the upload_max_filesize in the php.ini settings . You can just add this to the custom php.ini settings to change the upload. Change the value to what you need.

    upload_max_filesize = 250M
  3. Gino Carpanetti D.

    Gino Carpanetti D. New Member

    Hi CreeWarrior and thanks for your reply. I tried to solve the problem by the way you say, by editing the site in the Ispconfig Control panel directly but it did not work. Maby if i had just changed the version in the "IfModule" (from 5 to 7) without changing the size and then try the regular way it would have be an more elegant solution.
  4. loonatik

    loonatik New Member HowtoForge Supporter

    Did you try change them in /etc/php5/apache2/php.ini or /etc/php/7.0/apache2/php.ini?

Share This Page