Roundcube login then logout again

Discussion in 'Installation/Configuration' started by spikes, Aug 27, 2011.

  1. spikes

    spikes Member

    I have upgraded from debian lenny to latest debian squeese. The new server use dovecot instead. When I login to roundcube the user logs in for about 3-5 seconds and then log me out again. If I use remember me then login logout continuously. Thank you
     
  2. falko

    falko Super Moderator

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  3. CSsab

    CSsab New Member

    Try adding this to /etc/php5/apache2/php.ini

    [suhosin]
    suhosin.session.encrypt = Off


    This turns off suhosin session encryption globally and there are other ways to turn off suhosin session encryption only for roundcube if you'd rather put a .htaccess in the web directory of your roundcube installation.

    If you are still having problems change the default session lifetime in roundcube's main configuration file from the usual "30" to "50".

    Also make sure the following package is installed:
    php-mdb2-driver-mysql

    Hope this helps.
     
    Last edited: Aug 27, 2011
  4. spikes

    spikes Member

    Thank you for the response. I have tried all of the suggestions but it still logs me out. This is output from mail.log

    Aug 28 19:15:42 server1 dovecot: imap-login: Login: user=<steve@bla.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Aug 28 19:15:42 server1 dovecot: IMAP(steve@bla.com): Disconnected: Logged out bytes=39/449
    Aug 28 19:15:42 server1 dovecot: imap-login: Login: user=<steve@bla.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Aug 28 19:15:42 server1 dovecot: IMAP(steve@bla.com): Disconnected: Logged out bytes=301/1518
    Aug 28 19:20:01 server1 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Aug 28 19:20:01 server1 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
     
  5. falko

    falko Super Moderator

    Do you have the same problem with a normal email client (like Thunderbird or Outlook) or another webmail package (like SquirrelMail)? If so, it's probably a problem with your IMAP server, otherwise it's probably RoundCube-related.
     
  6. CSsab

    CSsab New Member

    After determining that this is a roundcube issue, the next thing to check are possible timezone issues.

    Log in to mysql as follows:
    mysql -u root -p

    and type this (to get the current time):
    select now();

    Does the output reflect your current timezone?

    I usually have the same problem on a new squeeze system until I fix a few things. I can post the configuration of my working roundcube if you cannot get this resolved.
     

Share This Page