Roundcube Error: Unsupported PHP version. Required PHP >= 5.4 and < 8.0.

Discussion in 'General' started by frank2018, Oct 24, 2021.

  1. frank2018

    frank2018 New Member

    Hello,
    i have installed "Perfect Server Automated ISPConfig 3 Installation on Debian 10 - 11 and Ubuntu 20.04" on Debian 11.

    Everything was perfect. But after a while i get this error:
    Unsupported PHP version. Required PHP >= 5.4 and < 8.0. You might need to manually install the phpX.Y package (for X.Y < 8.0) as well as phpX.Y-{cli,intl,json,mbstring}.

    I turned all Websites from php 8 to 7.4. But Rouncube doesn't work.

    ISPConfig is using php7.4

    Nice Greetings
    Frank
     

    Attached Files:

  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Where do you see this error?
     
  3. frank2018

    frank2018 New Member

    In the browser mydomain.de/webmail
    When i see the mailboxes in ISPConfig and klick on the mailbox symbol.
    And: webserver.mydomain.de:8080/webmail/
     
    Last edited: Oct 24, 2021
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Might be that you have installed or updated to mod_php 8? ISPConfig itself uses php-fcgi, so it can be that ISPConfig is working and using PPPHP fcgi 7.4 while Roundcube uses mod_php which was installed as PHP 8.
     
    frank2018 likes this.
  5. frank2018

    frank2018 New Member

    Thx a lot. I had installed nextcloud and needed some modules. In this session i had aktivated php8.0-fpm but i had forgotten it. I found it in my own documentation :)
    After
    Code:
    a2disconf php8.0-fpm
    and
    Code:
    systemctl reload apache2
    i can use Roundcube again :)
    Thank you for that tip. I was not sure if i could disable php8.0 modul. This tip gave me back my memory :)
     

Share This Page