Roundcube error 500

Discussion in 'Installation/Configuration' started by fbsoft, Dec 21, 2012.

  1. fbsoft

    fbsoft New Member

    hey guys,
    I've recently ported from SME Server to ubuntu, and installed Ispconfig 3 following the tutorial for the Perfect Server... All worked out perfectly untill i wanted to update and keep squirrelmail to roundcube. Followed the tutorial all worked good for the main domain, but, when i try to add a secondary one in ISPconfig, when i check try to access the domains webmail, it says error 500

    Now the config : /etc/apache2/conf.d/roundcube.conf

    Code:
    Alias /webmail /var/www/webmail
    <Directory /var/www/webmail>
      Options +FollowSymLinks Indexes
      # This is needed to parse /var/www/webmail/.htaccess. See its
      # content before setting AllowOverride to None.
      AllowOverride All
      order allow,deny
      allow from all
    </Directory>
    # Protecting basic directories:
    <Directory /var/www/webmail/config>
            Options -FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /var/www/webmail/temp>
            Options -FollowSymLinks
            AllowOverride None
            Order allow,deny
            Deny from all
    </Directory>
    <Directory /var/www/webmail/logs>
            Options -FollowSymLinks
            AllowOverride None
            Order allow,deny
            Deny from all
    </Directory>
    The outcome of the error log from /var/log/isconfig/httpd/www.domain2.com/error.log

    Code:
    [Fri Dec 21 12:16:21 2012] [error] [client xxx.xxx.xxx.xxx] SoftException in Application.cpp:221: File "/var/www/webmail/index.php" is not in document root of Vhost "/var/www/amcinromania.ro/web"
    [Fri Dec 21 12:16:21 2012] [error] [client xxx.xxx.xxx.xxx] Premature end of script headers: index.php
    So from this, i get it is not the docroot... but then why does the alias is for ?
    Also if i try to take a look at other configs... just to copy paste the redirect code, the manual ( the apache one ) works perfectly on both domains meening www.domain.com/manual and www.domain2.com/manual .
    Also the squirrel works well too... why ??? The config is almost the same !!! :)

    Thanks ppl
     
    Last edited: Dec 21, 2012
  2. falko

    falko Super Moderator

    Do you use SuExec or suPHP? If so, please disable it/use another PHP mode.
     
  3. fbsoft

    fbsoft New Member

    thanks and sry for the late reply, i was on a lil bit gone for these holidays.

    I use suexec of course but for the other domains not for roundcube config...
    Now the idea is why does it work on the primary domain that uses as suexecusergroup web1 client1 and not for the second domain, web2 client2
    How can i make it work on both domains... with the respective simlinks / aliases
    thanks
     
  4. till

    till Super Moderator

    use mod_php for roundcube like falko suggested. Take a look at the perfect server guides, they contain a chapter at the end that explains how to configure squirrelmail to use mod_php, the configuration for roundcube is similar.
     
  5. fbsoft

    fbsoft New Member

    Niiiiiiice, thanks guys, it worked, can be closed and marked as solved,
    P.S. For those who will read this, everything works perfectly on a Ubuntu Server 12.10 and Roundcube ver 0.8.4, and squirrelmail included.
     

Share This Page