Roundcube-Configuration Error - config.inc.php was not found.

Discussion in 'Installation/Configuration' started by George321, Jan 26, 2017.

  1. George321

    George321 New Member

    So today i tried to open my mailbox and i couldn't because of that:
    Screenshot_1.png


    Thanks
     
    Last edited: Jan 28, 2017
  2. DarkMaster

    DarkMaster New Member

    I have the same...
     
  3. George321

    George321 New Member

    Show me your mail.log
     
  4. ahrasis

    ahrasis Member

    Is it working before? Did you any update or reinstall?
     
  5. DarkMaster

    DarkMaster New Member

    @George321 - what would that accomplish? My mail.log contains only few lines that talk about the inability of monit to connect to specified port, nothing else...
    @ahrasis - yes, straight out of box it was working just fine, the after update it broke AND then after ISPConfig update it was working again and then some time - no clue when exactly, it was not anymore...
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux Distribution do you use and do you use apache or nginx web server?
     
  7. DarkMaster

    DarkMaster New Member

    @till Debian 8, nginx
     
  8. bookert

    bookert New Member

    Installed the Perfect server yesterday: Nginx with MariaDB Ubuntu 16.04. Was working fine, then all of a sudden same error. Do we have an update, please?

    It installs RoundCube but the URL to access: http://www.domain.com:8081/squirrelmail/
    Any advise how to fix this?
     
    Last edited: Mar 6, 2017
  9. ahrasis

    ahrasis Member

    For those who still have the complained problem with their roundcube, do check the /etc/roundcube/debian-db.php file whether it has the correct db user, password and database by accessing to phpmyadmin / mysql using that credentials. Do read the note inside that file as well. Do check whether you do have the complained file too.

    The default for apps is 8081 and you can change squirrelmail to roundcube (or other name) in apps.vhost but if you want it to be with your ISPC in port 8080, you have to add the same code to ispconfig.vhost.
     
    Last edited: Mar 7, 2017
  10. GoHod

    GoHod New Member

    Same issue here. Can log into phpmyadmin with details above just fine. Roundcube does work through the alias set up in the instructions (i.e. without using port 8081)
     
  11. Clemente Nogueira

    Clemente Nogueira New Member

    Hello, I notice that roundcube drops down with that message error after I check the System - Server config.
    The ISPConfig 3.1 auto saves and the roundcube pop this error message. It's the 3th time I test it. So, this is about ISPConfig 3.1 System configuration, but still not found what detail is it, because hapens without I change anything.
     
  12. AxelssonDesign

    AxelssonDesign New Member

    Hello, I have the same problem. Here is my error.log:
    2017/04/16 19:30:58 [error] 8389#0: *312 FastCGI sent in stderr: "PHP message: PHP Warning: Error writing to log file /var/log/roundcube/errors; Please check permissions in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1339
    PHP message: PHP Warning: SQLSTATE[28000] [1045] Access denied for user 'roundcube'@'localhost' (using password: NO) in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1441
    PHP message: PHP Warning: Error writing to log file /var/log/roundcube/errors; Please check permissions in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1339
    PHP message: PHP Warning: config.inc.php was not found. in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1441" while reading response header from upstream, client: 185.103.209.33, server: _, request: "GET /squirrelmail/ HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/apps.sock:", host: "45.76.82.53:8081"

    Anyone know how to fix ?
     
  13. ahrasis

    ahrasis Member

    1. Again, make sure you have the correct username and password for RC. The one that is used to access phpmyadmin should be the same withe one in db file.

    2. Check your folder permissions for RC error logs.

    3. Make sure you have that missing file.

    If problems continue, do try to re-install or upgrade RC.
     

Share This Page