Roundcube - big attachament problem

Discussion in 'Installation/Configuration' started by it0007, Dec 29, 2006.

Thread Status:
Not open for further replies.
  1. it0007

    it0007 New Member


    i have a problem with roundcube webmail
    when i try to send an e-mail with an attachament 1MB +
    NO message is sent

    in .../logs/errors
    i get
    PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate .... 
    PHP Warning: Cannot modify header information - headers already sent in .../ on line 132
    i can sent/recive mail with attachaments < 1 MB in size

    i add to Apache Directives in ISPConfig:
    php_value upload_max_filesize 50M
    php_admin_value memory_limit 32M
    what can i do ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install roundcube within a website or do you use the roundcube .pkg for ISPConfig?
  3. Hans

    Hans Moderator ISPConfig Developer

    Security update for RoundCube available

    One important note:

    On 22-12-2006 there was an important security update for RoundCube.
    This version is called: 0.1 beta 2.1.

    I just did an update to this version myself and everything looks ok.

    I think that the package provided (pkg-file) on the ISPConfig website is still based on the 1st beta version. At the moment we are two versions further.

    So, if there is no pkg-file available based on the latest security update, i recommend to setup RoundCube according my howto here:

    And if you want to increase the maximum upload size for your files, you can increase the post_max_size variable within your Apache2 php.ini file.
    (The package provided by ISPConfig is running on port 81 and use Apache 1.3, not Apache2).
    Last edited: Dec 29, 2006
  4. it0007

    it0007 New Member

    i installed roundcube according to this howto:

    i tried with the version 0.1 beta 2.1 from

    i copy the new version to a new location, overide configuration files with the old one and the same, i can't send mail with attachament bigger than 1 MB

    with phpinfo() i get:
    memory_limit          32M
    post_max_size          32M
    upload_max_filesize 200M
  5. Hans

    Hans Moderator ISPConfig Developer

    About your configuration files:
    I do not recommend to override the new main.conf and db.conf files with the ones, which belong to your earlier RoundCube version.
    If a new RoundCube version comes with new configuration files containing important modifications, you are not able to use it.

    Please use the new configuration files and change the necesarry lines as described within my RoundCube howto.

    About your attachment problem:
    Roundcube comes with an .htaccess file containing the lines:

    # AddDefaultCharset UTF-8
    php_flag display_errors Off
    php_flag log_errors On
    php_value error_log logs/errors
    php_value upload_max_filesize 2M

    <FilesMatch "(\.inc|\~)$|^_">
    Order allow,deny
    Deny from all

    Order deny,allow
    Allow from all

    If you are going to use this file (by uploading it within your /web, you'll have an 500 internal server error.
    For this reason, i did not use it.

    What you can try is to copy and paste the content of this .htaccess file within the Apache Directives field witin ISPConfig for your RoundCube website. Or at least the line:

    php_value upload_max_filesize 2M

    With the value, you want of course (MB).

    Please let me know how you're going with these settings.
    Last edited: Jan 1, 2007
  6. it0007

    it0007 New Member

    i did not delete the .htaccess file from temp/ folder
    now is working

    Problem Solved ;)
    Last edited: Jan 2, 2007
  7. Hans

    Hans Moderator ISPConfig Developer

    That's good to know! :)

    Happy RoundCube
Thread Status:
Not open for further replies.

Share This Page