roundcube and html editor

Discussion in 'General' started by aqua, May 1, 2008.

  1. aqua

    aqua New Member

    Has anyone had any luck with disabling the html editor from the latest (0.1.1) roundcube mail release? TinyMCE is buggy in this version, yet they still include it!

  2. Hans

    Hans Moderator ISPConfig Developer

    I don't know how to disable it completely but make sure that you have the following line within you RC configuration file config/

    // compose html formatted messages by default
    $rcmail_config['htmleditor'] = FALSE;
  3. aqua

    aqua New Member

    This setting seems to do what I want:

    Yet the compose html option still shows up. Anymore ideas?
  4. t-mug

    t-mug New Member

    Whats wrong with Tiny?

    Until now I havn't got any bad messages from my customers; whats wrong with the Tiny in Roundcube??
    Thank you for reply.
  5. aqua

    aqua New Member


    if you start out composing in plain text, then switch to html and then try to spell check the window layout becomes messed up.

    If you start out composing in html the spell check is not even available.
  6. t-mug

    t-mug New Member

    Thank you for the hint.
    $rcmail_config['enable_spellcheck'] = FALSE; is my quickie. Probably this is not what you want :(
  7. Hans

    Hans Moderator ISPConfig Developer


    I've tested what you descibed here in the forum and i can confirm your experience with html.

    - text is messed up, after toggling between html and plain text
    - spellcheck in html-mode seems to take forever
    - Toggling between plain text and html takes a long time

    As far as i can see there is no global option available within the configuration file to disable html, so users can turn on/off html.

    Hope RC version 0.1.2 is better on this point.
  8. aqua

    aqua New Member

    I signed up the RC mailing list and asked my question there. I was told to add this line instead:
    The does indeed remove the option from the settings pane, but it leaves the HTML editor radio button under the compose window visible... so thats not much of a help.
  9. make-fun

    make-fun Member

    Hi folks,

    unfortunately I also have to confirm the misbehavior of tiny.
    In addition to
    $rcmail_config['dont_override'] = array('htmleditor');
    I've a added a quick and dirty
    <td align="right">
    <!-- Quick BugFix
     <roundcube:label name="editortype" />:&nbsp;
     <span class="radios-left"><roundcube:object name="editorSelector" tabindex="9" /></span>


Share This Page