Roundcube 250 authentication error with ISPConfig 3.2.5

Discussion in 'Installation/Configuration' started by jnewman67, Sep 9, 2021.

Tags:
  1. jnewman67

    jnewman67 Member HowtoForge Supporter

    still working out the kinks of my Perfect Server CentOS 8 install

    Roundcube (or /webmail) isn't sending out emails. it reads them fine, just doesn't authenticate when sending. the
    /usr/share/roundcubemail/config/config.inc.php
    file is a copy/paste from the instructions.

    elsewhere, i've seen references to setting the user and password variables to default to spaces - that didn't work. and changing the SMTP from localhost to a tls://valid.server.name and port didn't work either.

    Thoughts on what I might be missing?

    thank you!
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Try
    Code:
    $config['default_host'] = 'tls://localhost';
    $config['imap_conn_options'] = array(
            'ssl' => array('verify_peer' => true, 'verify_peer_name' => false),
            'tls' => array('verify_peer' => true, 'verify_peer_name' => false),
    );
    $config['smtp_server'] = 'tls://localhost';
    $config['smtp_conn_options'] = array(
            'ssl' => array('verify_peer' => true, 'verify_peer_name' => false),
            'tls' => array('verify_peer' => true, 'verify_peer_name' => false),
    );
    $config['smtp_port'] = 587;
    $config['smtp_user'] = '%u';
    $config['smtp_pass'] = '%p';
    
    And ensure postfix is listening on 587. Or you can use the actual servername in your ssl certificate and forgo setting the connection options.
     
  3. jnewman67

    jnewman67 Member HowtoForge Supporter

    Beautiful! thank you very much - no need to do anything other than replace the existing "$config['default_host'] = 'localhost';" line with the chunk above.
    Again, thank you (and my apologies for the delayed response - it's been a long week!)
     

Share This Page