RoundCube 0.7 For ISPConfig 3 not working

Discussion in 'Installation/Configuration' started by onastvar, Feb 7, 2012.

  1. onastvar

    onastvar Member

    I've followed "How To Install RoundCube 0.7 For ISPConfig 3":

    http://www.howtoforge.com/how-to-install-roundcube-0.7-for-ispconfig-3-on-debian-squeeze

    I am unable to login using email as username and my password, it just bounces back,
    no messages, nor warnings. I also removed squirrelmail per How To.

    Couple of questions regarding my webmail.

    1) Where do I start to troubleshoot this issue?
    2) Is it best to reinstall SquirrelMail?
    3) How could I remove Roundcube?

    Thanks
     
  2. Horfic

    Horfic Member

    Are you using my plugins? (Mailuser interface for Roundcube)

    Enable all logs in the config file and try it again, afterwards look at them.
     
  3. onastvar

    onastvar Member

    Thanks for your reply

    I get the following when I restart apache:

    Restarting web server: apache2[Tue Feb 07 13:46:35 2012] [warn] The Alias directive in /etc/apache2/conf.d/roundcube.conf at line 2 will probably never match because it overlaps an earlier Alias.

    I have tried installing Mailuser interface for Roundcube but when I go to

    http://www.mysite.com:8080/remote/ i get a blank page

    also I'm not sure where to add, "Step 8 (Optional, but higly recommended)" from Installation Instruction

    Thanks
     
  4. Horfic

    Horfic Member

    The error means that the webmail alias /webmail is already somewhere used.

    http://www.mysite.com:8080/remote/ is supposed to be blank. Data is send and received by soap requests.

    Any other errors?
     
  5. onastvar

    onastvar Member

    I re-installed Roundcube in /var/www/webmail/ following the same guide. Right after installation, I was able to login and I check my email, sending/receving worked.

    After I installed "Mailuser interface for Roundcube" I cannot login no more.
    I'm getting "Login Failed" on Roundcube login page.

    Any ideas why, what setting should be checked?
     
  6. Horfic

    Horfic Member

  7. onastvar

    onastvar Member

    Yes I downloaded files from the link.

    This is my file var/www/webmail/config/main.inc.php

    Code:
    // ----------------------------------
    // PLUGINS
    // ----------------------------------
    
    // List of active plugins (in plugins/ directory)
    $rcmail_config['plugins'] = array("jqueryui","ispconfig3_account", "ispconfig3_autoreply", "ispconfig3_autoselect", "ispconfig3_pass", "ispconfig3_spam", "ispconfig3_fetchmail", "ispconfig3_filter", "ispconfig3_forward", "ispconfig3_wblist");
    Does this look fine?

    I've added Apache Directives to

    ISPConfig > Sites >mysite.com > options (tab) > Apache Directives

    <DirectoryMatch \.svn>
    Order allow,deny
    Deny from all
    </DirectoryMatch>

    Is that correct?

    Thanks for your replies & help in advance :)
     
  8. Horfic

    Horfic Member

    As I said, remove the autoselect plugin...

    Code:
    $rcmail_config['plugins'] = array("jqueryui","ispconfig3_account", "ispconfig3_autoreply", "ispconfig3_pass", "ispconfig3_spam", "ispconfig3_fetchmail", "ispconfig3_filter", "ispconfig3_forward", "ispconfig3_wblist");
     
  9. onastvar

    onastvar Member

    Thanks Horfic, that worked, I was able to login. Another questions, under

    Roundcube > Account > Mail Filter

    I see

    IMAP Error in /var/www/webmail/program/include/rcmail.php (639): rcube::imap_init(true) is deprecated, use rcube::imap_connect() instead

    Any ideas what I could do to fix the IMAP Error?

    Thanks
     
  10. Horfic

    Horfic Member

    Yeah I will need to fix that, but it shouldn't concern you.
     

Share This Page