RoundCube 0.2-stable available for ISPConfig 2

Discussion in 'General' started by Hans, Dec 31, 2008.

  1. Hans

    Hans Moderator ISPConfig Developer

    On 30-12-2008 RoundCube 0.2-stable has been released. Based on this latest stable version, i've built a new package for ISPConfig 2. It is also my last contribution to this community for this year.

    RoundCube 0.2-stable can be downloaded here. Please read the available readme file for install instructions. The previous stable RoundCube version 0.1.1 is also still available.

    Happy RoundCube and i wish you all a happy 2009! :)
     

    Attached Files:

    Last edited: Dec 31, 2008
  2. pjo

    pjo New Member

    Hi,

    I try to install roundcube 0.2 on a ISPConfig installation (to which I moved another ISPConfig installation), and I always get

    Installation instructions not found: /home/admispconfig/ispconfig/temp/e6e9aaba36448a363b872b7dc6b7348a/package.ins

    This occurs in both ways, upload and URL. What am I doing wrong? Any ideas?

    Thx pjo
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Do not unpack the .pkg file before you upload.
     
  4. pjo

    pjo New Member

    Thanks for reply!

    Till, I do not unpack the pkg before uploading (and and as I wrote direct URL gives the same error).

    Could it have an impact, because during migration of data from server A to server B I copied the whole /home/admispconfig folder?
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. pjo

    pjo New Member

    Hi Falko,

    yes I tried it with different ones. Since my last post I recognized that I cant update with any pkg, although it worked (with myphpadmin) at Server B before migration from Server A (according to that thread).

    So something might have happend during migration...

    Thanks pjo
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have verwritten anything in /home/admispconfig/ on the new server then it might not work anymore. These directories should not be overwritten with any files or content from the old server.

    Please post the output of:

    ls -la /home/admispconfig/ispconfig/
     
  8. pjo

    pjo New Member

    yes I transfered /home/admispconfig/ to the new server...
    Any ideas, how to repair?

    here's the ls output:

    root@xxxxxx:/home/admispconfig# ls -ltra ispconfig/
    total 4760
    drwxr-xr-x 4 admispconfig admispconfig 4096 2008-02-13 00:01 files
    drwxrwx--- 2 admispconfig mysql 4096 2008-02-13 00:01 backup
    drwxr-xr-x 4 admispconfig admispconfig 4096 2008-02-13 00:01 ..
    -rwxr-xr-x 1 admispconfig admispconfig 203 2008-02-13 15:50 users
    -rwxr-xr-x 1 admispconfig admispconfig 862 2008-02-13 15:50 sysconf.txt
    drwxr-xr-x 18 admispconfig admispconfig 4096 2008-02-14 10:04 web
    drwxr-xr-x 11 admispconfig admispconfig 4096 2008-02-18 12:41 tools
    -rw-r--r-- 1 root root 255208 2008-07-23 11:28 ispconfig.log.23-07-08_11-28-47.tar.gz
    drwxr-xr-x 10 admispconfig admispconfig 4096 2009-01-05 12:10 temp
    -rw-r--r-- 1 admispconfig admispconfig 4552869 2009-01-05 23:59 ispconfig.log
    -rw-r--r-- 1 admispconfig admispconfig 11 2281-03-18 11:04 adminmail.txt
    drwxr-xr-x 6 admispconfig admispconfig 4096 2281-03-18 11:42 lib
    drwxr-xr-x 8 admispconfig admispconfig 4096 2281-03-18 23:38 .
    root@xxxxxx:/home/admispconfig#


    And here:

    root@xxxxxx:/home/admispconfig# ls -ltra ispconfig/temp/5ee21591a812370662de8c587d4439ca/
    total 1532
    -rw-r--r-- 1 admispconfig admispconfig 1553989 2009-01-05 12:03 roundcu.pkg
    drwx------ 2 admispconfig admispconfig 4096 2009-01-05 12:03 .
    drwxr-xr-x 10 admispconfig admispconfig 4096 2009-01-05 12:10 ..
    root@xxxxxx:/home/admispconfig#
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Download the latest ispconfig 2.2.x version and run the setup script to update your server, this should repair the contents of these folders as well.
     
  10. pjo

    pjo New Member

    I updated with 2.2.29 and now it works!

    Let me just shortly remark, that now after updating I have to use https to connect to my :81 ISPconfig, before I had it unencrypted, but this is also ok, so it forces me to more security :)

    At this time let me say thanks to you for your great support and howtos and of course for developing ISPConfig in such a perfect way. I use this software now for nearly two years in a production environment and it never disappointed me!

    Keep on doing the great work! If 3.0 is stable and the update/migration procedure will be not too strange, I'm sure I will do the same good experiences as I did in 2.x.

    Regards, pjo
     
  11. madmucho

    madmucho ISPConfig Developer ISPConfig Developer

    I installed it on testing server, configure and works fine, i see many changes :)
    But when new client enter roundcubemail his mail in profile is created in format mail@www.domain.tld. I know there was some fix for previous version which trim www from virtualuser file when roundcube create new user. Have someone lines which i need to change in this release?
     
  12. Hans

    Hans Moderator ISPConfig Developer


    Please have a look here.
    Currently there is no solution for this.
     
  13. warlock

    warlock New Member

    If I have the old version of roundecube, can I just upgrade by installing this one over it ?
     
  14. Hans

    Hans Moderator ISPConfig Developer

    Please have a look here for the upgrade instructions.

    By upgrading this way, you must realise that the current sqlite database will be overwritten and user identities and settings well get lost.
     
  15. mumbly

    mumbly New Member

    Hi !
    I've got some "weird" behaviours with Rouncubemail 2 stable package for Ispconfig.
    Most of the time, i can't read messages. (some rare exceptions though ...)
    I click on the "Object" and i can see "Loading ..." ... and nothing ! I could wait 1 hour, it would still be the same !
    Moreover, the Settings page is all "messed up" with titles that cross over some others... I think it could just be a css problem or something like that...

    I must say it's a "Brand New" ISPConfig 2.2.29 install on a fresh Ubuntu 8.10 server.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log or in the error log in /root/ispconfig/httpd/logs?
     
  17. mumbly

    mumbly New Member

    No error ... but i found a "turn over" : i've turned off the html display in the Roundcube Settings and all went ok !
    What about that ?
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Not sure - I've never used Roundcube... I could've helped if there was a problem in the mail setup itself, but this seems like a Roundcube problem...
     
  19. crypted

    crypted New Member

    I've enjoyed RoundCube in the past. However, I just updated to the latest Roundcube and I cannot get it to work without port 81. I want to get in a default HTTP port. Right now I have to just make a redirect to the port 81 link. However, I am in the military and so I cannot check my mail from work as they filter all ports except 80.

    Any ideas?
     
  20. Stanev

    Stanev New Member

Share This Page