RoundCube 0.1-stable package available for ISPConfig

Discussion in 'General' started by Hans, Mar 4, 2008.

  1. Hans

    Hans Moderator ISPConfig Developer

    Did you enable php for that website within ispconfig? You must not rename it!
     
  2. ralfba

    ralfba New Member

    it is ...

    php is enabled, and when i SSH into the box and look into it,

    isp01:~ # which php
    /usr/bin/php
    isp01:~ # php -v
    PHP 5.2.5 with Suhosin-Patch 0.9.6.2 (cli) (built: Feb 11 2008 20:32:19)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    isp01:~ #

    i enabled both php options ... the web belongs to a client i created, the reseller is the "normal" admin entry
    ralf
     
  3. Hans

    Hans Moderator ISPConfig Developer

  4. ralfba

    ralfba New Member

    obviously something is wrong ... or i am to stupid

    when i point the browser to the installer subdir i allways get the file index.php for download, and the browser asks me where it should be stored ...

    i tested this with firefox and IE - no difference.
    did i do something wrong with the php install???
    ralf
     
  5. Hans

    Hans Moderator ISPConfig Developer

    What's in your Vhosts_ispconfig.conf?
    Any warnings in /home/admispconfig/ispconfig/ispconfig.log?
    Any errors in Apache's error log?
     
  6. ralfba

    ralfba New Member

    the log doesn't show any errors in the past days ...

    Code:
    ######################################
    # Vhost: www.rcmail.de:80
    ######################################
    #
    #
    <VirtualHost 192.168.120.21:80>
    ServerName www.rcmail.de:80
    ServerAdmin [email protected]
    DocumentRoot /srv/www/web10/web
    ServerAlias rcmail.de
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    Alias  /cgi-bin/ /srv/www/web10/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /srv/www/web10/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On
    php_admin_value open_basedir /srv/www/web10/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /srv/www/web10/phptmp/
    php_admin_value session.save_path /srv/www/web10/phptmp/
    Alias /error/ "/srv/www/web10/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web10/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web10/user/$1/web/$3
    </VirtualHost>
    
    the logs for the web itself are all in their initial status i guess ...
    Code:
    isp01:/srv/www/web10/web/error # ls -lrt
    total 28
    -rw-rw-r-- 1 root web10 1225 Mar  6 23:15 overloaded.html
    -rw-rw-r-- 1 root web10 1174 Mar  6 23:15 methodNotAllowed.html
    -rw-rw-r-- 1 root web10 1163 Mar  6 23:15 invalidSyntax.html
    -rw-rw-r-- 1 root web10 1215 Mar  6 23:15 internalServerError.html
    -rw-rw-r-- 1 root web10 1172 Mar  6 23:15 forbidden.html
    -rw-rw-r-- 1 root web10 1181 Mar  6 23:15 fileNotFound.html
    -rw-rw-r-- 1 root web10 1190 Mar  6 23:15 authorizationRequired.html
    -r-------- 1 root root     0 Mar  6 23:15 .no_delete
    
    :(
     
  7. Hans

    Hans Moderator ISPConfig Developer

    Please within ispconfig turn php safe mode to off.

    Why do you have all these lines within your Vhost?

    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On

    Make sure that you configure php according the howto you've used to setup your server.
     
  8. ralfba

    ralfba New Member

    tried already to run it without the save-mode, but it didn't change anything ...
    i used the "perfect-setup guide" for setting up the host.
    the box is running opensuse 10.3 ...
    why i do have these lines in it i don't know, since i am not an expert on webserver configs.
    ralf
     
  9. edge

    edge Active Member Moderator

    Hans,

    Not sure if this is a bug, and if you know a fix for this, but I do get a lot of the following error's when "Prefer HTML" is set to on (it's under Personal settings)

    I see a lot of the following in html made up emails:
    When I set the "Prefer HTML" to off the emails are looking fine.
     
  10. Hans

    Hans Moderator ISPConfig Developer

    I don't have problems with that. Everything is functioning as it should. Html or not.

    The problem with the RC package for ISPConfig (sqlite version) is that i can't check the sytem requirements because the installer is not delivered with the package, because it is a upload and go solution.

    The only thing i had to change on my servers (a requirement for RoundCube) is that you have

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    within your php.ini file.

    Make sure it is not turned on!

    Hope it will work for you!
     
    Last edited: Mar 9, 2008
  11. ralfba

    ralfba New Member

    new install?

    hi Hans,

    what do you think - should i reinstall the box ???`
    as of today, i only have email-services running on this ispconfig - therefor i tried to use roundcube.
    is there any way how i could check the genral availability and function of PHP?
    greetings - ralf
     
  12. Hans

    Hans Moderator ISPConfig Developer

    I can't make the decision about reinstalling software on your server or not, however it is very important that you setup your linux server exactly to the howto. If you plan it to use your server within a production environment you also need to test it before you start to use it.

    You can verify your php configuration by creating an info.php file with the followng contents:

    <?php
    phpinfo();
    ?>
     
  13. ralfba

    ralfba New Member

    checked the install - no difference

    hi Hans,
    i checked the installation of the OS and could not find any difference to what i did or what currently is installed. So - what to do?
    the test with the little info.php has the same outcome as the one coming with roundecube. the browser is always trying to find an application to open the php-file with ...
    i copied the info.php to a different web, but the behaviour is still the same.
    :-(
     
  14. jbravo

    jbravo New Member

    Check this out:

    In file /home/admispconfig/ispconfig/lib/config.inc.php

    Code:
    $go_info["server"]["apache2_php"] = 'addhandler'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)
    Above setup is SUSE10.* compatible (works ok on SLES10 too).
     
  15. ralfba

    ralfba New Member

    one workaround ...

    the only workaround i found so far is, to put the following line into the apache-directives box
    Code:
    AddHandler application/x-httpd-php .php
    if this line is in, i can open php-files as it should be ...
     
  16. TomC

    TomC New Member

    Hi Hans,

    there are two things within the ISPConfig RoundCube package that I would like to talk about to someone who knows what he's doing... ;-)

    1. I want to configure RoundCube to connect via TLS (on Port 143) with my Courier IMAPd. I know that using SSL is pretty easy (ssl://localhost:993), however, tsl://localhost:143 doesn't seem to work. Is there any way I could do that? RoundCube is at present the only reason why I still have imapd listening on port 993.

    2. Placing the whole RoundCube package in the web-directory of ispconfig makes it possible to read _all_ files through a simple web browser. The .htaccess files don't have any influence anyway. And even if they did I don't feel good placing unnessessary data in a world readable directory...

    I'd love to hear your opinion and/or suggestions on these subjects.

    Thanks and regards,
    Tom
     
  17. tred

    tred New Member

    bug?

    If I activate preview panel, each second choice of a letter maximize it at full screen, not to preview area. It`s bug of RCM?
     
  18. Hans

    Hans Moderator ISPConfig Developer

    @tomC
    I did not test RC with TLS, so i do not know the answer for sure. you can try to change the line

    $rcmail_config['default_host'] = 'localhost'; into $rcmail_config['default_host'] = 'tls://127.0.0.1:993'; within config/main.inc.php.

    All the packages for ISPConfig which you can download at ispconfig.org are installed within the ispconfig/web directory. Also RoundCube.

    @tred,
    Maybe your problem is browser/plugin related.
    The RoundCube package for ISPConfig is 100% fine, but it does not come with the installer script which is provided by RoundCube. With the installer script the system requirements for RoundCube can be checked. So without it the system requirements for RoundCube can't be checked. The only thing you must change on a default ISPConfig server for RoundCube is that you need to change:

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    within your php.ini file.

    Otherwise RoundCube will not work properly.

    One more note:
    I use RoundCube -0.1 stable successfully and as far as i can see there are no minor bugs as suggested within this thread.

    My RoundCube 0.1-stable package has been tested but it needs the right system requirements. This package is a upload and go solution.

    @All,
    Because of the many questions about the new RoundCube 0.1 stable package, i decided to create an extra package which is exactly the same as the 0.1-stable package, but contains also the RoundCube installer script.

    Important note:
    The right configuration files db.inc.php and main.inc.php are delivered with the package and are configured already to let RoundCube work properly. This means that you don't need to create these new configuration files with the installer script again. The advantage of the installer script is that you can verify your system requirements and change them if necessary.

    The extra RoundCube 0.1-stable package with the installer script included can be downloaded here.

    After uploading the package with the update manager within ISPConfig, you can find the installer script at http://domain.tld:81/roundcubemail/installer/index.php.

    If you don't need the RoundCube installer script anymore, please remove the directory /home/admispconfig/ispconfig/web/roundcubemail/installer for security reasons!


    I do hope that the additional package will help you all to setup the right system requirements for RoundCube 0.1-stable!
     
    Last edited: Mar 13, 2008
  19. nocture

    nocture New Member

    This is bag ?

    [​IMG]
    :confused: :eek:
     
  20. Hans

    Hans Moderator ISPConfig Developer

    Your question is not really a question, but what you see is normal.
    You see the messages within a list and below it the preview window of the message.
    If you don't want this you can disable it within the config/main.inc.php file by changing the line:

    // default setting if preview pane is enabled
    $rcmail_config['preview_pane'] = TRUE;
    into
    // default setting if preview pane is enabled
    $rcmail_config['preview_pane'] = FALSE;

    The picture in the background is the RoundCube logo
     

Share This Page